Jump to content
Sign in to follow this  
Skyfox01

Is this a bug ???

Recommended Posts

Hi,

if I enter the code below I got an unexpected result. It looks like a bug in the program! [Mad][Confused]

please Enter the code and try to draw it ...

Use a point Object!

Procedure Test;

var

hd :array[1..3] of handle;

Begin

arc(1690,910,-130,-910,180,-65);

hd[1]:=lnewobj;

arc(1430,650,130,-650,180,-65);

hd[2]:=lnewobj;

clipsurface(hd[1],hd[2]);

hd[3]:=prevobj(lnewobj);

delobject(hd[2]);

End;

Run(Test);

If you are making the band smaller, VW doesn't draw anything! The problem occures only within Angles around 60 degrees!

Is there anyone, who can help me to solve this problem?

I need this very urgent!

Thank you.

Kind regards,

Skyfox! [Confused][Confused][Confused]

Share this post


Link to post

That code worked fine for me as a script. I did not try it as a plugin tool script.

What happens if you comment out the "DelObject(hd[2])" statement?

Share this post


Link to post

Martin,

I'm sorry. That first test ran no problem in VW 11.0.1; when I tried it in VW 11.5.1 I got the same behavior you described.

When I ran through with the debugger in 11.5.1, I observed that the Handles stayed nil after the Arc calls. Even stranger, occasionally the variable window was completely blank. Not sure what is causing that except maybe the Editor plug-in got corrupted and is trying to access the wrong thread.

Share this post


Link to post

The script works for me from a script palette in 11.5... as long as the attributes palette is set to solid. It fails if set to none.

I guess an unfilled arc has no surface to be clipped.

What happens is that there's no resulting object from clipsurface, so it draws one arc, then another and deletes the second one. Not sure why you're seeing Nil handles though.

If you're still having problems, you might remove everything in the script except the arc calls, and see if you can get the desired result by choosing clip surface from the menu after the arcs are drawn.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...