Jump to content

Tapered Extrude trouble


Recommended Posts

code:

	Procedure Test;

VAR

H:HANDLE;

BEGIN

Rect(0,0,100m,100m);

H:=CreateTaperedExtrude(LNewObj, 0, 100m);

END;

Run(Test);
[/code]

Can anyone tell me why this code draws a Tapered Extrude 0,10m (10cm) thick instead of 100m thick?

It seems to always draw it 1000 times smaller, did I do something wrong?

[ 02-07-2005, 03:00 PM: Message edited by: Alexandre B A Villares ]

Link to comment

The Real variable "100" for the extrude defines a height, not a length... you may change your object orientation (or the working plan) to use the function over the length.

10cm are 100mm, he looks like your vector script need to mach the document units, for 100m you'll need 100000 units if you document is in mm.

Hope this is of any help!

Link to comment

Many programming languages do not handle 0 as a variable value well.

Try making your initial tapered extrude variable value something small like 1 mm, expressed appropriately for your default units setting, and see if this makes a difference. This will to all intents and purposes look the same for your purposes.

Also try expressing your units without the unit identifier - set them appropriately for your default units settings.

Link to comment

I thought we were supposed to be able to use unit identifiers in script....maybe that's where is the bug? I've used them to no ill effect.

Maybe you'll need to do that get units and *UPI rountine that's so popular in the NA scripts.

I've no idea what kind of object Tapered Ex is supposed to produce, but 6 ungrouped NURBS seems odd (maybe).

So what happens if,as Mike suggests,you use it without unit identifiers? Unfortunately I haven't upgraded in quite a while, so I can't test this myself. (soon to make the move)

good luck Alex

Link to comment

The run script in 11...

I try with the unit identifiers, and I do get a 100m extrusion on a 100m*100m rectangle.

With out the units identifier, he follows properly the document units...

on both cases I obtain a rectangle and 6 ungrouped nurb surfaces corresponding to the extrusion.

I then try 100*100 rectangle, extruded to 100m and this work too...

But is a non sense... the VS function doesn't produce the same results than the tapered extrude tool!!!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...