Jump to content
Sign in to follow this  
JB Campbell

Clipped object causes crash?

Recommended Posts

I have a script for creating panels that is giving me some difficulty. One portion of the script is used to create a panel with a hole but it cause the VW8.5 to crash when I invoke this option. Does anyone have any insights here? The block of the script that I is used for this is included below.If more of the script is needed please let me know, I'll be glad to email the full script. http://www.nemetschek.net/ubb/images/icons/confused.gif

{Object Creation Code}

NameClass('None');BeginGroup;BeginXtrd(0",9/16");ClosePoly;PenSize(7);PenFore(0,0,0);PenBack(65535,65535,65535);FillFore(0,0,0);FillBack(65535,65535,65535);BeginPoly; MoveTo(0",3'10"); LineTo(0",0"); LineTo(1'11",0"); LineTo(1'11",3'10");EndPoly;EndXtrd;ResetOrientation3D;Rotate3D(#90? 0' 0" ,#0? 0' 0" ,#0? 0' 0" );Move3D(0",0",0");NameClass('plex/clear');BeginXtrd(3/32",15/32");FillPat(0);Rect(1",3'9",1'10",1");EndXtrd;ResetOrientation3D;Rotate3D(#90? 0' 0" ,#0? 0' 0" ,#0? 0' 0" );Move3D(0",0",0");EndGroup;Record(LNewObj,'Record ID');Field(LNewObj,'Record ID','Module #','0');Field(LNewObj,'Record ID','#','1');Field(LNewObj,'Record ID','Part','CK-PPW23-46');Field(LNewObj,'Record ID','Description','46" Flat Panel 23"');Field(LNewObj,'Record ID','Finish','SS');Field(LNewObj,'Record ID','Button','NB');Field(LNewObj,'Record ID','Each','155.00');Field(LNewObj,'Record ID','Price','155.00');SetView(#-90? 0' 0" ,#0? 0' 0" ,#0? 0' 0" ,0",0",0");SetZVals(0",0");

Thanks JB Campbell

Share this post


Link to post

Do you want to make a solid substraction of the two extrudes or should the resulting object look like a frame? Please can you explain a little more? If you could send me the whole code an maybe a sample file what you want to get as result i'd be glad to help you.

Hannes

Share this post


Link to post

Thanks for the quick response.

The object is to represent a panel with a plexiglass insert. The script seems to create the object ok but VW crashes after a couple of subsequent actions, doesn't seem to matter what those actions are. So I thought that something in the creation was perhaps left unresolved.I will email a copy of the script seperatly.

JB Campbell

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...