Jump to content
  • 2

VW2024 terrible lag on second monitor


Greg Mitchell

Question

Just upgraded to 2024.  Everything I do, i.e. zooming in and out with the scroll wheel has a 1-2 second delay.  I didn't have this problem on 2023.  It doesn't happen on my laptop screen.

I'm on a Macbook Pro M2 Max running Sonoma 14.1.2

I have tried connecting through my USB doc and directly to HDMI.

 

Any ideas?

  • Like 2
Link to comment

Recommended Posts

  • 1

M1 MacBookPro 64GB. I also am having this problem on both 2023 and 2024. It seems to only be with VW open. I have tried swapping between USB-C and HDMI cables. It is to a 4K Monitor. It doesn't seem to make a difference if I run it in 4K of 1920x1080. Reducing the VW window from full screen to any size less than full screen seems to improve it but does not fix it entirely. It seems to be worse on more complex drawings. It completely goes away with the disconnection of an external monitor.

 

 

  • Like 2
Link to comment
  • 1

Vectorworks 2022 SP6

Macbook Pro M3 Pro 18GB

MacOS Sonoma 14.4.1

Asus ProArt 4K Display PA279CRV as main display connected over USB-C

 

Terrible lag when especially when dragging view when window fully maximised (not full screen), but improved when window slightly minimised. Also improved if the Macbook is closed without being extended display. Previously used 2020 M1 iMac and this starting to not feel like an upgrade.

  • Like 1
Link to comment
  • 0

Hi I got this Lag as well. Thought it was a problem that my system update to sonoma was activated, before the release of servicepack 2.

But still got the problem again. I'm Running Vectorworks 2024 on a Macbook pro 14" M1, with Sonoma 14.2.1. 

I've got two external monitors connected via HDMI=>USB-C connectors. 

 

I hope you can help in this matter.

 

kind regards 

Marco

  • Like 1
Link to comment
  • 0

Yes , haven't found a solution yet and it is making working with any external display and Vectorworks untenable.  I also teach in a classroom where I use a projector as a second display and it has made it almost impossible to teach Vectorworks in that setting.  It only happens with Vectorworks, no other programs.  I hope I can find a solution other than reverting back to 2023 along with all of my students.  😞

  • Like 1
Link to comment
  • 0

Hi

I have the same problem but I'm still on 2023. I'm on a Macbook Pro Apple M3 Max, 36GB Ram and running Sonoma 14.1. Using a 4k monitor connected with HDMI.

 

I had the same problem on my old Macbook Pro 2019 which prompted me to upgrade. Immensely frustrating to still be in the same boat. I find that I can control the lag a little better if I make the Vectorworks window smaller on my external monitor instead of full screen. But running it on full screen bogs down the whole computer. I've attached a screenshot of my activity monitor with vectorworks acting up during scrolling and zooming then then a second screenshot with vectorworks on fullscreen on my external monitor but using chrome (to write this post), vectorworks in the background. You can see the windowserver is still hogging all the CPU. This is repeatable.

 

I hope there is an answer!

 

Regards,

Helena

Vectorworks full screen but running in background.png

Vectorworks not full screen scrolling and zooming.png

  • Like 2
Link to comment
  • 0

Noticing this in Vectorworks 2023 and 2024, don't even need a second screen for this to be an issue WindowServer maxxing out when using Vectorworks is very common in our office of over 40 staff. It is becoming a big issue. 

Link to comment
  • 0

Same Issue here..

 

Vectorworks 2024 Update 5

MacBook Pro M3 Max

16 core CPU - 40 core GPU - 64Gb RAM

MacOS Sonoma 14.5

 

I'm brand new to VW.. loaded up VW for the first time today and noticed it was laggy to the point of being unusable.. I've seen this sort of lag before, it brought back memories of using Adobe Premiere and After Effects on my at the time brand new M2 Ultra Mac Studio. It took Apple and Adobe several versions to work out the bugs, but they finally got it working smoothly. There was a workaround with the adobe apps.. if you set the spaces setting to "displays have separate spaces" it would speed up the adobe apps.. I didn't take the time to do that with VW, but maybe there is something there.. I just personally refuse to work like that.

 

At my desk I'm using a 43" LG monitor connected via HDMI through an OWC Thunderbolt 3 Dock. I discovered that If I move the VW window to the built in Macbook display, VW is wicked fast. Also just like Khalil above, if I shrink the window on the LG monitor to something less than fullscreen, VW will speed up.. this is the option I settled on. Just wanted to throw this out there.. maybe the devs will see this any have some ideas of where to look.

 

- Daniel

  • Like 2
Link to comment
  • 0
Posted (edited)

Same issue here on fully loaded M2 Max MacBook Pro.. It's intermittent as well which makes it impossible to fix. @jblock any ideas?

 

It causes the second monitor to freeze up and then catchup or generally lag regardless of if VWX is on it or not. No issue with it on the primary screen but sometimes it will simply not let both screens run smoothly. 

Edited by Ben B
Additional Information
  • Like 1
Link to comment
  • 0
  • Vectorworks, Inc Employee

This is a known issue with macOS 14. Our development team is in communication with Apple and hopefully they will have a fix soon. 

  • Like 2
Link to comment
  • 0
16 hours ago, Pat Stanford said:

What computer are you running on?  Does it meet the hardware requirements for VW?

 

I don't think this is the problem. Before the upgrade to Sonoma 14.5 it worked perfectly and the computer is quite powerful.

Macbook Pro 14" 2023

Apple M2 Max

64gb ram

4tb

 

Link to comment
  • 0

Hi there! Curious if any fix has been seen on this? 

 

For reference I have not had any issue with VWX 2023 until about 2 months ago. Now basic functions (especially Zoom) are extremely laggy on an external monitor, but VWX works perfectly fine on the main laptop screen. Nobody drafts on a solo monitor so I hope there is a fix incoming

 

Thanks!

Link to comment
  • 0

I just started having this issue as well. At first I thought it had to do with the file. After cleaning the file up and removing/simplifying any complex geometry, moving internal origin, etc. issue remained. Then I realized the issue is with any file despite the file size and complexity. Following this, I reset the preferences but the issue still persists. After additional forum searches I came across this thread. It appears the lag is on my second monitor and completely goes away if VW is moved back to my MBP. 

 

My stats are:

Vectorworks 2024 Update 5

MacBook Pro, Apple M2 Max

MacOS 14.5 (23F79)

Philips PHL 276E8V as main display connected over USB-C

 

Hope someone has a workaround....

 

Link to comment
  • 0

M3 Max /48gb / Sonoma 14.5 vwx24spotlight most recent updates.


Same issues, for months.(I believe jan24) Its impossible to get my job done in time, and have to rebooth my system many times a day.

(with Mac 16" i9/2019 vwx 20/21/22/ i can't remember i had to rebooth once for years)

 

Black flickering VWXscreen, laggy sytem, slow VWX.

What I have done:

Empty black desktop, closed every other app even dropbox, (but sometimes chrome, mail or textedit is needed), all OSX visual fx turned off.

Also set the LG4K to 1920*1080/30hz, tried on direct HDMIoutput and direct USB-C

Checked if I am not running any legacy components in vwx.

 

I just installed VWX23, runs slighty better in shaded view, but the rest of the system is not workable, hard to type any letter in textedit without seconds delay.

(happens when I switch to a different view)

 

When VWX is closed, windowserver runs normal, and the system runs perfect, without to need to rebooth.

Link to comment
  • 0

I found for myself a workarround solution: (after testing also other displays & cables)
Set ext. display as main screen, and run vwx complety on the ext display.
All other applications on the macbook screen. 

I experienced less lag, and able to run multiple drawings now for half a day without rebooting
when windowserver is peaking above 100%(mostly when moving drawings) , the other applications will react normally.

I also get the tip to downgrade to MacOS 14.2, but I didn't find the installer yet

Link to comment
  • 0

@Peter Neufeld. I actually found that turning off 'Displays have separate Spaces' dramatically helped navigation, however the lag persisted when you started to use any tools, i.e. start to draw or edit rather than just navigate / view.

 

For the time being, the only way that I have been able to work around this is to work on a single screen, albeit there seems no difference if I use the laptop or external screen. As soon as I try to use both, I get this lag.

Link to comment
  • 0

I am having the same issue.  This is what I am seeing along with my process.

 

I specifically notice issues when watching videos on my second monitor, such as certification courses, youtube, and training.

Before working in Vectorworks, I run Automator to turn off all third-party apps that run at login. (Google Drive, Dropbox, Creative Cloud, etc.)

I then open Vectorworks on my main monitor (no problems yet)

Here is where the problems start

I open any file, and the video starts to stutter, not the audio; it continues playing normally. This is the same result when scrubbing the video.

Sometimes Vectorworks itself will hang up, but that is rare.

 

My troubleshooting:

Lowered 3D Conversion Quality

I moved to 2 QHD Monitors with MacBook lid closed (Typically, I run 3)

All Files I am actively working on are stored on my internal SSD.

Tried displays with spaces and without.

 

My System

16" MacBook Pro - M1 Max

64 GB RAM

2 TB Internal Drive

Sonoma 14.5

Vectorworks 2024 Entertainment Bundle

 

I do not get this same behavior on my windows system.

  • Like 1
Link to comment
  • 0
16 minutes ago, KevinF1973 said:

I am having the same issue.  This is what I am seeing along with my process.

 

I specifically notice issues when watching videos on my second monitor, such as certification courses, youtube, and training.

Before working in Vectorworks, I run Automator to turn off all third-party apps that run at login. (Google Drive, Dropbox, Creative Cloud, etc.)

I then open Vectorworks on my main monitor (no problems yet)

Here is where the problems start

I open any file, and the video starts to stutter, not the audio; it continues playing normally. This is the same result when scrubbing the video.

Sometimes Vectorworks itself will hang up, but that is rare.

 

My troubleshooting:

Lowered 3D Conversion Quality

I moved to 2 QHD Monitors with MacBook lid closed (Typically, I run 3)

All Files I am actively working on are stored on my internal SSD.

Tried displays with spaces and without.

 

My System

16" MacBook Pro - M1 Max

64 GB RAM

2 TB Internal Drive

Sonoma 14.5

Vectorworks 2024 Entertainment Bundle

 

I do not get this same behavior on my windows system.

Just tried opening Vectorworks file then Google Chrome.  I am not getting the issue.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...