Jump to content

atan node bug?


Recommended Posts

I'm building a network and am trying to use a "atan"-node. It seems however that whatever I try I can't get a proper output from the node. I tried feeding it with both int, real and dim numbers, but always get the same error, as shown below. I brought in a math friend and he believes there might be an error in the code, specifically a part called bComplex, but we don't know how to edit the node so we couldn't try our hypothesis. Anyone know if there is a bug in the atan node or if I'm missing something? @Marissa Farrell perhaps?

 

2003956767_Skrmavbild2022-11-12kl_10_52_46.thumb.png.4675eedc5c8e35db40dee554c2ead509.png

  • Like 1
Link to comment
54 minutes ago, Marissa Farrell said:

Yes, there's a missing line of code. 

 

In the #inputs section, add 

 

bComplex = self.Params.bComplex.value

 

You'll also need to delete the first line in the script that begins with #COMMAND

 

This has already been fixed for next service pack. 


Thanks for confirming! I’ll wait for the next update then.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...