Jump to content
  • 0

Objects invisible in shaded view

Marcel Ostendorf




I installed VWX 2023 (same with 2022) in my VM (Parallels 18 with Win11 ARM on Mac M1 Max). Everything is fine and the performance is just outstandig, but in shaded mode all objects are invisible. In Parallels I assigned 6 CPUs, 32GB RAM and 16GB graphics memory to the VM and within Windows I have set VWX to High Performance in System - Display - Graphics. I also reinstalled Parallels Tools but nothing helped.


Has anyone seen this before and solved it?



Link to comment

14 answers to this question

Recommended Posts

  • 0

For me it looks like a normal graphic glitch.


Like using a too weak, not recommended (onboard ?) GPU

or bad drivers.

But given that Virtual Machines, even with Parallels, usually

do not offer the latest or full features of Graphic Frameworks

like OpenGL, DirectX, ....


And the whole thing even needs the ARM/X86 emulation ....


1 hour ago, Marcel Ostendorf said:

I have set VWX to High Performance in System - Display - Graphics.


I would rather lower graphic demands of VW than using max Settings.




I was used to witching back in direction of OpenGL compatibility mode

in previous years in VW very often,

as soon as any graphic or visibility issues occurred.

Although this was always on a nativ OS installation.


Around 2007 I ran my Microstation on a virtual Machine of Windows

by Parallels on my Mac Pro. It was unrealistically slow and lagging.

Took me long time until found it is the full screen cross hair cursor

that was the issue. Usually needing some of those old legacy OpenGL

features that Parallels virtual graphic device obviously did not offer.

Once deactivated and set to a standard cursor, whole Microstation

worked as expected, fast and fluid .....

Link to comment
  • 0
  • Vectorworks, Inc Employee

It may be a error stored in the file VGM graphics cache, a possible solution is to turn the graphics caching off save and restart Vectorworks.
The Save VGM graphics cache is in the File menu> Document settings>Document preferences

If this fixes the issue you can turn the caching back on afterwords, as it create a new cache which shouldn't have the old error in it aymore

Link to comment
  • 0
21 hours ago, Marcel Ostendorf said:

According to Parallels, it should be possible to run apps that require DirectX 11 and OpenGL. Since Shaded View is based on DirectX 11, I would expect it to work.


I can't know what exactly happens or is supported.

But I think it could be worth to try to switch everything back to compatibility modes

and check if it works. Then increase settings until it fails again.

Edited by zoomer
Link to comment
  • 0

Regardless of what settings I choose, all objects remain invisible in the shaded view.


Things I tried so far:


In Windows:


System - Display - Graphics:

- Let Windows decide

- Powersaving mode

- High performance


Uninstalled and reinstalled Parallels Tools, uninstalled and reinstalled graphics card driver.


In Parallels Desktop:


Settings - General:

- switched between configuration "Games" and "Design"


Settings - Hardware:

6 CPUs, 32 GB RAM, (up to 16 GB for graphics)


In Vectorworks:


- deleted VGM cache

- turned hardware acceleration off / on


It seems to me that the shaded view simply doesn't have access to DirectX, which (according to Parallels) should be emulated through Metal.

Link to comment
  • 0

I try to install a Windows Version on Parallels on my m3 for special Support- and Training cases. 
After all i found out, Parallels 19 needs a Windows 11 ARM Version. And on a Windows ARM Version, the Installer of Vectorworks 2024 will not start. Somebody have experience with that constellation?



Link to comment
  • 0

Hi Marcel
Thank you very much for responce. So far my experience, that it was able to install VW with an alternative Windows Image (Win 11 ARM). After starting VW Mentioned, that some vlb was not able to load. (Cinerender)


After That VW works quiet smooth and fix in 2D, but in 3D nothing visible. Like you mentioned. Also no wireframe model. 
After Deactivated the Parallels Display driver, the 3D Shaded view is visible but it is very slow. Also a bigger modell crash.

Next Test with VM Ware Fusion. Test-Version. I only have two CPU cores. I hope this is because of free Test Version. 
After Installing Windows 11 with the same iso image i was able to install VW. With VM Ware Fusion it was able to install something like VMWare Tools. This installing Drivers also Display Drivers. After Restart i have a Graphic Adapter Named VMWare SVGA. Then I start VW. It Installation and startup of VW is slower than on parallels. But on Parallels I had 12 CPU Cores and on VWMare Fusion . Only two. After Shut Down the virtual Machine i can set up more cores

It seems to be good enough for testing, Support but not for really working or offering as a Training Computer for Customers. Additionally Cinema 4D do not run at all. But Shades View is OK.





After giving the virtual Machine more than 4GB RAM, it works better 🙂
But Still generating the 3D Takes more time and the double emulation (Mac Silikon > Windows ARM > Win 11 ARM > Winx86 VW) seems to be incompatible to the VW Render-System.

Edited by DomC
Link to comment
  • 0


does VW run well directly on real Windows for ARM devices ?


If, then the rest would be just Parallels or VMware not offering proper

GPU faking support. DirectX in that case.


My VM Ware and Parallels experience is a bit dated.

I ran my Microstation via VMware and later via Parallels (2007-2009 ?)

to avoid Bootcamp and be able work on OSX.

At that time it was still OpenGL.


But my experience was that VMware was super slow in general and OpenGL

support was not enough to run Microstation reasonably enough,

while Parallels was much faster generally and offered sufficient OpenGL

performance for realistic 3D working on larger projects.


But what did not work nevertheless ...

older legacy OpenGL features like e.g. full screen crosshair cursor did slow

Microstation down unrealistically.

(Unfortunately I worked that way for half a year until I finally figured that out ...)


So I think for support, running VW on Windows

a) on a VM and

b) with an extra ARM X86 emulation

may add some extra layers of unreliability.





Link to comment
  • 0

I think there is no difference between VMWare or Native ARM System. Vectorworks run in "compatibility - Mode" on ARM Windows. except in VMWare or parallels it is just slower. From my sight, VMWare seems to play in one league higher than parallels.

Emulating Software somehow does hurt my hart but if i really look at my Solution:

1. Money was spent on a very nice and powerfull M3 max (How i love that machine ...)
2. Running the Emulation thing is a sacrilege but in fact: I can run A Windows system with an startet Vectorworks in 20 Seconds! by just pausing the Virtual machine and saving the state:
3. Speed and lags are comparable to a Medium Windows System which is 3 Years old. Still i need much less power to work on that system
4. Additionally the hope, that update of Windows and native ARM Software will even improve the situation

If i look at the facts in that moment i will not buy a new pc for some time and i think i will practice this "sacrilege" workflow. 

  • Like 1
Link to comment
  • 0
1 hour ago, DomC said:

VMWare seems to play in one league higher than parallels.


That is good to hear.

I always preferred VMWare overall. But at that time frame it was unfortunately

always overall slower and realistically not usable for professional 3D CAD work,

at least wit Microstation.


I am sure public ARM switch on Windows will not be as fast as with Apple.

I do not really follow the Windows X86/ARM emulation nor Parallels/VMWare

progress but would be excited when Windows-only Apps run reasonably on

Windows ARM emulation and even VMs.


Or VW running well on a Windows VW on Linux.


1 hour ago, DomC said:

I can run A Windows system with an startet Vectorworks in 20 Seconds! by just pausing the Virtual machine and saving the state:


While testing Windows 10 in a Parallels VM on Mac (during Apples most bad hardware offers 2012-2020)

I was also sure I could easily switch from Mac back to Windows .....

No need to care for most hardware drivers, BIOS updates, ..... and super fast boot times.

Once testing real (BTW great) PC hardware, Windows looked a bit different and I also tried

Linux but decided to suffer a bit longer with Apple.

At least since M2 or M3 I feel confident my patience with Apple was wise.

Link to comment
  • 0

After Working a little more in this environment and Drawing some Modells. I see a little better the lag in user-interaction. Not slow but the little lag, that would let us loos a game or missing the string of a guitar. I short: Nothing  for Vectorworks Artists ... 

Also i see, that some (loved) tools (Ähnliches Aktivieren) and menu commands (Edit Workspace works but not Exit and save) wont work. And I am sure, some further issues i will see. Menu looks strange, seperators looks like empty lines in menu commands.

Issues see with
- Tool Ähnliches Aktivieren
- Callout Tool
- Auto Dimension
- Elevation Benchmark
- Measure Angle
- Grid Axis
- Eye Dropper
- Parallel Tool

Just too many tools do not work it looks ... 

Promising at the first look, the second look is  disapointing but still better, than i thought but for me no alternative to a native Windows System. 😢

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...