Is it the beam of light or the lit fog? There is a bug with the lit fog not stopping at surfaces, but the light should cast shadows.   Make sure though that you have shadows checked in shaded mode options and also for good measure, make sure that receive shadows is checked in the background which is in the resource manager.
    • Like