Jump to content

Wonderfully Wacky Behavior


Recommended Posts

Now that the job is done, I have time to describe a bit-map tool rendering behavior I found both frustrating and brilliant - if it can be harnessed.

Dual 400mhz G4, OS 10.2.8, VW 9.5.3, 832mb memory. 27mb 3D architectural model at 1/16" scale, no background. Various views set by Save Sheet with Layer Links.

Normal behavior when using Bit-Map tool is that non-model areas - the background - will render as white pixels and when the bit-mapped (raster) image is copied and pasted into Photoshop, those white background pixels are there, they are white. OK, that's normal.

Now for the Wonderfully Wacky. I'd been rendering my final images when I started to notice a single light grey "scan line" appear in the otherwise white background. Sometime later while rendering a different image, the same line appeared again, only this time is was black and there were several of them. As I rendered away numerous times on my five final views the backgrounds continued to erode until at one point, all white areas in the image (including those "white" areas even within the model image) were rendering as solid black. TALK ABOUT FRUSTRATING!!! I'm at the end of this project and now all of sudden my rendering engine goes haywire. FORTUNATELY, I was pasting into Photoshop for file size reduction and other modifications when I noticed that the areas that rendered "black" when they should have rendered "white", were not black at all - but TRANSPARENT. I couldn't believe it. The ability to bit-map render with transparancy.

So what is it? A bug? An Opportunity? Stikes me the behavior lies in the rendering engine memory (or memory leak). Could my video-cards (I have 2 monitors) have anything to do with this?

Oh yes, I certainly did all the normal things like Restart, higher and lower resolutions, etc. as the problem progressed.

Link to comment

The render bitmap tool uses the settings of Custom RenderWorks. If you have transparency enabled under View>Rendering>Custom RW Options, you'll get transparency.

But the odd thing is that it started as white and went on to black.

Between each of the bitmap renderings, which I am going to understand as being quite alot, did you close VW and restart VW to try again to see if you still got the black lines?

Link to comment


All the model elements are solid fills or textured.

The transparency only occured where the final pixel color in the bit-mapped image would be white (background, hi-lights on white glass street light globes, white lettering in full sun, etc.).


I'll have to check out whether transparency was enabled via ViewCustom RW Option or not. I'm sure it was because I want (and have) somewhat transparent glass, but what would that have to do with non-object backgrounds becoming transparent?

And oh yes, I certainly did a lot of quitting, restarting, etc. as I progressed. I've been using MiniCad and VW with rendering for 6-8 years now at least, so I'm pretty familiar with the applications. This strikes me as a hardware/software interface memory problem.

Thanks for the replies.

Bob Roesler, architect, Memphis

Link to comment
  • Vectorworks, Inc Employee

Hello again Broesler:

Please double-check that the rendered bitmap object's fill is set to None. This is the exact behavior I would expect. When bitmaps are drawn with a None fill, colors at or near pure white are drawn transparent.

Link to comment

Dave -

Maybe I don't understand your question correctly. When you state "the rendered bitmap object's fill is set to None", I assume you are refering to the 3D model object. When you you say "When bitmaps are drawn with a None fill..." , I'm not positive I understand this. Does the Bit-Map render tool have an option I'm overlooking, or are you again refering to the 3D model object.

As far as my model objects go, no doubt about it, all model objects are solid fill or textured. The basic "transparent rendered" behavior I'm describing is not about what happens to solid 3D objects, it's about what happens to the background.

The "sky area" (the background) degraded over time to the point where it rendered transparent rather than a rectangular-bounded area where the non-model areas (sky) are white pixels. The fact that areas within the model where the specular high-lights create an all white pixel also turned transparent (and by "transparent" I mean: there is NO PIXEL of any color, that area is transparent) is simply consistent with the rendering engine turning what should be a white pixel background into a transparent (non-existent) background.

I am not complaining. I'd love to be able to reliably reproduce the behavior. The final effect was identical to a bit-mapped image with an alpha channel mask hiding the background.

Link to comment
  • Vectorworks, Inc Employee

Hello again Broesler:

What I mean is, select the bitmap object that the Render Bitmap Tool creates. In the Attributes palette, is the fill (paint bucket menu) set to None?

If it is, setting the fill to Solid will get rid of the transparent pixels.

Link to comment

WOW - that does work.

Setting the fill of a bit-map image created by the Render Bit Map Tool to NONE, does indeed eliminate all the white pixels - rendering the non-object areas of the image transparent. THIS IS GREAT.

Thanks for showing me how to achieve this effect whenever I want. I still don't understand what caused the behavior in the first place, but I don't care.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...