Jump to content

Xform not able to move Martin Sceptron fixture


Recommended Posts

Hello

I am having some issues moving Martin Sceptron fixtures with the X form function. 

I tried a bunch of objects, and fixtures, and they all move fine. However the sceptron 10 don't seem to. 

For reference, I tested moving my floor, and a Mac Viper. They both move fine. 

 

Fixtures are imported via MVR, from Vectorworks. 

However I also tried to place one directly from the vision library, and had the same problem. 

 

I tried to put them into the layers, and move the layer above. But the same issue. 

Did any of you experience this issue? 

 

I attached some screenshots, and my showfile. 

Best from Mathias

 

 

Screenshot 2022-09-05 100049.png

Screenshot 2022-09-05 100118.png

Screenshot 2022-09-05 100348.png

Screenshot 2022-09-05 100517.png

Sceptron array.vsn

Edited by mhersland
Spelling :)
Link to comment

I made more tests. 

To me it seems like there has been some changes to xForm? 

 

When trying to move an object, I t disappears. 

Have a look at attached screenshots. 

 

Here all DMX settings are made, except Delta X / Y / Z. 

 

 1540533549_Skrmbillede2022-09-06kl_15_15_12.thumb.png.ef77a5f144ccb1d100d7f248bab4fca3.png

 

 

When entering a delta value. The element diapers completely. 

 

1247726085_Skrmbillede2022-09-06kl_15_15_22.thumb.png.e48303cc62a2f4e0814f6f3248cee6ff.png

 

Do any of you experience the same behavior? 

And have a solution for this? 

Link to comment
  • Vectorworks, Inc Employee

Not sure whats happening there!

Maybe @Mark Eli might be able to shed some light on these...

I have discovered a workaround...

Create a new layer in the scene graph and drag the fixtures into this layer, then apply the transform to the layer not the individual fixtures.

  • Like 1
Link to comment
  • Vectorworks, Inc Employee

I'll have to investigate if some fixtures not being transformed is intended behavior or not. I don't think it is, but first I'll have to figure out exactly why it's happening.

The recommended workflow is, as @TomWhiteLightsaid, using layers. It's faster and easier to work with all around. Using layers also gives you the ability to nest transforms of all objects or subsets of objects within the parent layer, so it has quite a bit of flexibility.

 

As for objects disappearing, I have not been able to replicate it. It could be something specific to the geometry you're using, or something I'm doing different. I'm not really sure. I have way more questions than answers, if you can share that specific file it would definitely make replicating the issue easier. If you're not comfortable sharing it on the forum, feel free to email us directly tech@vectorworks.net

If neither is an option, I have a lot of questions. It looks like you were already sending DMX to the X channel when you entered the Delta X, what happens when you pull that channel to zero? What happens of you change the Delta X to something higher or back to zero? Does changing the Delta Y instead of X have the same or different effect? Did this happen with any other objects, or possibly it happens with all the objects with the same geometry? Does it happen after restarting your computer?

 

In general using layers instead of manipulating individual objects should keep you moving forward in any project you're currently working on.

  • Like 1
Link to comment

Hi @Mark Eli

I will share my file with you in your mail. 

 

I found out, it changed when turning up the quality in the preferences. 

It happened a couple of times after that, but after changing the quality up or down all objects came back. 

 

I got your point about using layers. For this project we are currently sketching. So making 81 layers every time I import the objects was quite time-consuming. 


 

Link to comment
  • Vectorworks, Inc Employee

I got your point about using layers. For this project we are currently sketching. So making 81 layers every time I import the objects was quite time-consuming. 


 

 

Quote

I assumed the MVR merge command would not change any pre-assigned layers, If this is not the case, let us know and I will report a bug.

 

Link to comment
  • Vectorworks, Inc Employee

Unfortunately this is a bug. I'm not totally sure what's causing it at the moment, but I will be submitting a ticket so we can get it fixed.

@mherslandI've tried everything I can think of, and I haven't been able to make any geometry disappear. If this keeps happening, please do let us know so we can look into it further.

 

I have found a workaround for working for the fixtures you and @Ben59 mentioned. It may actually be an easier workflow for you.

You'll create an empty file with empty layers that have your transforms set. When you open a new or modified file you're working on in vision, you'll merge in the file with the layer transforms by using File>Merge. Then drag and drop the fixtures you want to have dmx xforms into the layers. So you'll still have to assign all 81 xforms to 81 layers, but you should only need to do it once, and then after you can drag and drop.

 

Just in case I'm explaining this poorly, I've made a file as an example. You should be able to merge this file into any other file, then move any fixtures or geometry into the layers and each layer is individually controllable.

XFormLayers.vsn

  • Like 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...