Jump to content

Search the Community

Showing results for tags 'pdf'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements
    • Announcements
    • News You Need
    • Job Board
  • Feedback
    • Wishlist - Feature and Content Requests
    • Known Issues
    • Wishes Granted / Issues Resolved
  • General
    • Troubleshooting
    • General Discussion
    • Architecture
    • Site Design
    • Entertainment
    • Vision and Previsualization
    • Braceworks
    • Rendering
    • Workflows
    • Buying and Selling Vectorworks Licenses
  • Customization
    • Marionette
    • Vectorscript
    • Python Scripting
    • SDK
    • 3rd Party Services, Products and Events
  • Solids Modeling and 3D Printing
    • Subdivision
    • Solids Modeling
    • 3D Printing
  • Vectorworks in Action
  • Archive
    • Resource Sharing
    • Machine Design

Categories

  • Knowledgebase
    • Tech Bulletins
    • Troubleshooting
    • Workflows
    • How To
    • FAQs

Categories

  • Marionette - Objects
  • Marionette - Networks
  • Marionette - Nodes
  • Marionette - Menu Commands

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Occupation


Homepage


Hobbies


Location


Skype

Found 19 results

  1. Benson Shaw

    v2019 pdf snap bugs

    Couple possible pdf bugs, at least on MacOS side. I'm on High Sierra. Bug 1. •Import a vector based pdf into v2019, or v2018 (might be same situation in earlier versions). •Result is shows as PDF Page in OIP. •Toggle the OIP Snap to Geometry and verify that snaps are working. •Duplicate in Place the PDF Page (OIP identifies the dupe as PDF Page). •• The Bug: •On my system, the Snap to Geometry is still checked, but cursor cannot detect any snap points. Same lack o snaps if toggle the Snap option off/on. •• The Workaround: • Cut/Paste (including Paste in Place). Now the snaps work. OIP option also works to enable/disable snaps. Bug 2. • Use v2018 to open a v2018 file containing at least one vector PDF Page. (I haven't tried earlier versions) • Select the PDF Page and verify that the Snap to Geometry option toggles access to the snaps. • Enable the Snap to Geometry option. Save and close the v2018 file. • Open same file with v2019 and accept the conversion. • In the v2019 file, locate & select the PDF Page, and verify that Snap to Geometry is enabled. On my system, same bug as above. No snaps, even if toggle the Snap option. Same Cut/Paste workaround, too. General Notes: A PDF Page exhibiting the bug ungroups as expected to reveal the Bitmap, the white rectangle, and the geometry. (v2018 & v2019) I'm curious whether others can replicate. Win & Mac. -B
  2. I've imported a PDF. it is 11.6 MB. 4 pages, but I'm only taking in 3 of them. I've un-grouped the PDF. I've deleted the bitmap and a number of rouge rectangles. I also found that AFTER i've un-grouped the PDF, i'm left with an additional, 'hidden' group inside that group. I double click that group, and enter the group edit window. There, I have to manually pull the additional 'layers' from the PDF out to get to the line bits. Then I exit the group edit window and I have my layer of lines. in fact, I'm left with a really nice bunch of lines and polygons. About 700,000 polygons. I run a 'Compose' command on a bunch of them and that drops the number by almost 100,000. I'm still left with a bunch of polygons that have a fill associated with them. I need that fill gone. I've tried several things here, but the result is the same - It takes forever. If I do a custom select, and only select polygons that have a fill associated with them, I get a more manageable number of like 58,744 polygons. I move to the format pallet and choose the 'no fill' option. I get a beachball spinning for a long time, and the fill state never changes, and I have to apple+option+delete out of Vectorworks. By a long time, I mean hours on hours. If I do a smaller selection (like 15 - 20 polygons by tedious hand selection), or marquee select small sections of the drawing, I can change the fill state and it only takes minutes. Like 10 - 15 minutes. Still, to me, that seems like a really long time. My questions are this: Am I asking too much of the software? Is this 'expected' behavior in real world applications? Is there a better way to remove fills from polygons on a drawing? Is there a good way to 'pre-prep' a PDF for import? This PDF has no layers, and isn't that big. Working on my import PDF - turn it into a model workflow. So far, it's great. Except the underwhelming speed of the fill removal. The 'breaking apart' of the PDF takes a little bit of time, but not nearly the time that the fill removal does. Not by a long shot. Repro steps - Set up new drawing File-import PDF. highlight PDF. Apple+U to un-group Delete the rectangle and the bitmap so I'm left with just a singe 'group' item. Double click that group item. Enter the group editor. delete the various rectangles that represent the 'pages' or white space in the PDF. Exit editor. you're left with several 'blobs' or groups of PDF parts. In my case, I imported 3 PDF pages. Now I have three big groups of lines and Polys. Click the group of lines and Polys. Apple+A (yes, you are doing this a second time). Now you have a bunch of lines and poly's on your layer. Custom select: type = Polygon Fill = (solid black box in my case) Check OIP, verify there are like 60,000 polys selected now. click format pallet. on fill pull-down, select 'No Fill'. leave the office an literally come back in the morning. Might be done.
  3. Aristobulous

    Export Current View w/ Clip Cube on

    This is weird. I want to take a quick screen capture of a room layout to send to a colleague. I am in OpenGL with Perspective, and have the Clip Cube active to remove the "fourth wall", but my PDF export is ignoring the Clip Cube. That seems weird. Thoughts?
  4. Benson Shaw

    PDF Page snap anomaly

    I found a PDF Page anomaly. Probably a bug with a strange and easy workaround. The Setup: •Import a pdf with vectors. •Same result if Drag/drop or File>Import>Import PDF •Enable the OIP option for Snap to Geometry. •Verify that the snaps are working •Duplicate (cmd D) the PDF Page. •Note that the Snap option is enabled in the duplicate. The Bug: Snaps to geometry in the duplicate PDF Page are not working, even though the OIP option is enabled. Toggle the option off/on does not cause enable the snaps. The Workaround: Copy/Paste the duplicated PDF page. (delete the Dupe if desired) Snaps in the Copy are working as expected. Notes: 1. The snap dead duplicate(s) can be ungrouped and the underlying vectors are available as expected. 2. Same results if PDF crops are in play. Cropped duplicate has no snaps (except the perimeter crop points). Copy/Paste of the cropped duplicate snaps as expected. -B PDF Snaps.vwx
  5. Dear VW lovers, when importing multiple PDF files into VW - either onto Design Layers or Sheet Layers - then the screen slows down when I am looking at a page and resize the view itself only. It looks like VW is somewhat 'processing' the view of the PDF files and it takes a while for all PDF files to be visible when I change the page view %-percentage. And it's just time-consuming waiting and slows down my work processes a lot. BTW - pushing the 'Escape' button on my MAC does not help. My current VW settings - don't know if they have anything to do with it - are at 'Good Performance and Compatibility' in the VW Preference Settings. Any thoughts are much appreciated. Cheers, Grethe
  6. António da Cunha

    Export 3D PDF - Layers Order

    Is it possible to influence the order of Layers and classes when exporting 3D PDF? I have an order of Layers 01, 02, 03, etc... and I want them to be exported in that order as a 3D PDF and stay in that order when opening my PDF viewer. Is this possible? Right now they stay in a disorganised order. Thank you!
  7. Good day, I have recently noticed that my Tekton Pro font, when either exported or published to pdf, and when the text has been left-justified, then the pdf text will have little rectangles with crossed lines introduced to the text block. Take a look at the attached pdf for a visual. I have also included the vectorworks file. After checking through the kbase conversations, I hadn't landed on a specific statement about support for open type fonts in recent years. There were some posts about ten years ago. My hunch is that something changed with the recent 2018 version, or one of the subsequent service packs as I had no previous problems with this font in 2017. I would like to be able to export to pdf, and then have my fonts available for last minute editing by Acrobat DC. And yes, I can rasterize the text blocks just fine without any incident. And I have deleted and reinstalled the font on my mac prior to reaching out to this forum. Any insights will be greatly appreciated. Thanks, Brian ireland_font_test_180426.vwx ireland font test 180426_8.pdf
  8. Mikedk64

    Printing / PDF issues

    Hi, I have this problem where, when i creating a pdf through "File - Export - Export PDF" the PDF looks fine. But when i am printing the drawing or creating a PDF thorough "File - Print - Microsoft Print to PDF" some lines a missing and there a added some other lines. This do also happen if I am printing the totally fine PDF created from "File - Export - Export PDF" I have multiple sheeet layers in this file, but it is only this sheet layer that doing it. Is this some issues with my printer or VectorWorks? This is a bit of the correct PDF where all lines are there. Here is the wrong one, where some lines are missing.
  9. Kenny Green

    2018 PDF Export Text Unreadable

    Surprise Surprise... upon exporting a PDF using 2018 Service Pack 2. The text is now totally Unreadable. I checked the Raster Text option and it looks like my text has been written with a crayon. Anyone else experiencing this issue and whats the fix?? Here's a screengrab of in-program view and exported PDF view. Here's the exported PDF
  10. I'd like to be able to set the white background of a PDF imported into Vectorworks to transparent, to make checking against our own drawings easier. This way we can lay them *over" our own drawings to check co-ordination, instead of having to lay them under our drawings (like we can with DWG files).
  11. To export PDFs from VWX i use FILE > PUBLISH > PDF I then save the PDF to the relevant folder in our shared company dropbox. We have multiple users producing different drawings for different projects, so sometimes i can easily find a PDF for a items, but am unsure as to which VWX file it came / was generated from, as we have vartious referenced VWX files for each project. Is there any way we can inbed as a piece of meta data in the PDF file the parent VWX file the PDF was generated from ? We are running VWX 2014 Architect
  12. Benson Shaw

    Publish PDF vs Print to PDF

    Tried to create an AsBuilt.pdf with Publish command from sheet layers in a single vwx file - no referenced files. Several problems: 1. All text was rasterized by the Publish process. The Publish dialog options were not enabled for rasterize drawing and rasterize text. This is an old complaint, but worth mentioning again. Fonts are Arial and a smattering of Avant Garde. 2. Huge file resulted. 21 pages came in at 143MB. Options for PDF layers were not enabled. Adobe Reader choked on some of these pdf pages, taking about 30 seconds or more to load. Watching these pages open was like watching a time lapse movie of the various symbol instances and other drawing elements appearing one at a time until the whole page was populated. 3. Assembling a pdf doc from individual pages made with MacOS Print to PDF at 300dpi brought the assembled pdf doc size down to 14MB. Did I miss some Publish settings? -B
  13. We are using Vectorworks 2016 (Architect) on Mac. One particular file has started deleting viewports from the Sheet layers when we export them. This feels like a glitch. The Navigation pane suggests that the viewports still exist - but they are no longer on the sheet layer than the Navigation pane says that they are on. I've no idea where to even start diagnosing this problem - any assistance greatly appreciated! Sam
  14. Is it possible to have a PDF insert to match my background? I am drawing with a black background and want a white background PDF or TIFF to be inserted with a black background and lines to be white or colored by the class that they are inserted on. Please tell me this is possible. Thanks.
  15. Where we have to markup photos as part of a presentation, we import them into vwx as a jpeg / png as relevant, place them on the sheet layer and red line, markup annotate them etc. The issue is when we come to PDF them, the file size is often HUGE, the most recent one with 4 c. 2mb jpegs taken from an iphone6 became a 90mb PDF when published. My current workflow is to then import these into Adobe acrobat and compress them, making sure the image quality is set to 150DPI, which leaves me with a file size of around 2-5mb. Is there a way i can get the compression to happen as part of the PDF publishing process native in VWX ? --- VWX 2014.
  16. Josh NZ

    VW2017 Publish Time

    I have around 6 sheet layers with about viewports. I went through and updated each viewport individually as wanted to check their appearance. Process took around 5 minutes as not particluary large or complex. I have now published the same sheet and left the option ticked to publish viewports as I find it safer to leave on expecting would take a smilar amount of time to render all again. Its now been about over 20 minutes and still not finished publishing. A script message appears on the screen with the message "publishing layer of internal item 6 of 6". The background screen of my VW has gone black with no other dialog. Is this a bug or has anyone else experienced this?
  17. Im trying to add a hyperlink (a piece of text that when clicked on takes you to a website, rather than just a 'naked' URL) to a website in a piece of text added to a sheet layer so that when i PDF the sheet layer the link is hyperlink is clickable from the PDF, but im pretty lost as to how to do this in VWX.. any ideas ? Thanks
  18. Good Afternoon All, Just a quick one, as a first-time thread poster - does anyone have any idea of the below: "When exporting a file from within Vectorworks to a .PDF format (Adobe Acrobat DC), the file in question is being flipped to a different page layout type then what is set in Vectorworks". I have had a look in the application that I am trying to export too (Adobe Acrobat DC), and I cannot see any setting that can be set that would allow the page type to be set as is when exporting. On the plus side of this, when I then Publish a file in Vectorworks and export to PDF, it will be the same page layout and scope as it is seen in Vectorworks. Has anyone else had this problem? If so, what measures were put in place to correct this? Thanks in advance to any responses. TheArtist.
  19. rja/a

    Batch PDF Export

    Cannot export Batch PDF in VWX2016 and cannot find Batch Export Plug-in in my VWX2013 file to move it over to 2016. Any suggestions.

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×