Jump to content

Search the Community

Showing results for tags 'mac'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements
    • Announcements
    • News You Need
    • Job Board
  • Feedback
    • Wishlist - Feature and Content Requests
    • Known Issues
    • Wishes Granted / Issues Resolved
  • General
    • Troubleshooting
    • General Discussion
    • Architecture
    • Site Design
    • Entertainment
    • Vision and Previsualization
    • Braceworks
    • Rendering
    • Workflows
    • Buying and Selling Vectorworks Licenses
    • Hardware
  • Customization
    • Marionette
    • Vectorscript
    • Python Scripting
    • SDK
    • 3rd Party Services, Products and Events
  • Solids Modeling and 3D Printing
    • Subdivision
    • Solids Modeling
    • 3D Printing
  • Vectorworks in Action
  • Archive
    • Resource Sharing
    • Machine Design

Categories

  • Knowledgebase
    • Tech Bulletins
    • Troubleshooting
    • Workflows
    • How To
    • FAQs

Categories

  • Marionette - Objects
  • Marionette - Networks
  • Marionette - Nodes
  • Marionette - Menu Commands

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Occupation


Homepage


Hobbies


Location


Skype

Found 14 results

  1. So, service Pack 3 has been released and I see that the window extents STILL do not move when a line or cursor comes up to the edge of the drawing window. This is a MAJOR issue and this should have been resolved by now. I am running the latest MacOS (Mojave). Yeah, if you wiggle the cursor just right at just the right place, one MIGHT get the window to scroll along.... Note this is about working within the drawing window, not using scroll bars. Can someone advise when this will be fixed? Cheers, BW
  2. Hi, I am just starting off with python for Vectorworks - I use Visual Studio Code (VS Code) as my IDE on a Mac (MacOS 10.13) I have downloaded vs.py but I have no idea how to set up VS Code to "see" vs.py for intelli-sense or linting The instructions: "To help intelli-sense for Vectorworks Python script APIs, you can point your IDE to the file File:Vs.zip (download, unzip, and place it appropriately so the IDE could find it)" don't help me much. Can anyone explain the steps needed to point VS Code to vs.py (or an alternative)?
  3. Does anyone know if there's another key I can use other than the default "control" key + middle mouse button to initiate the flyover tool "on the fly" (ie. without formally clicking on the flyover tool (Shift-C)). Thanks!
  4. Hi, I have a 2018 Designer License with Renderworks for sale. I purchased it from Vectorworks on 11/27/17 and realized I won't be using it and would like to sell it. I spoke with the account rep today and it just requires a transfer form to be filled out and turned in to the company. Make me an offer worthwhile. I will update this post once it's sold. UPDATE: THIS HAS BEEN SOLD
  5. jpccrodrigues

    Pc vs Mac for VW?

    I started using Vw Landmark around 6 months with my pc with Windows 10. But from the begining I heart about the optimization of Vw for the Mac plataform. As I’m going throught increansingly complex projects, I would like to know your opinion: is there really a difference between plataforms or is it just “fan talk”? What is the “best suite for the Vw 2018? Thank you very much!!! ps: I tried to search the theme on the forum and didnt found any discussion.
  6. Probably for Jim... With the introduction of new iMacs, and the end-of-year iMac Pro, is/will VW2017 be compatible with High Sierra? Of particular concern is the new file system Apple is introducing as evidenced by Microsoft's stated limitations: http://appleinsider.com/articles/17/06/13/high-sierra-leaves-microsoft-office-for-mac-2011-behind-2016-edition-needs-updating
  7. tekbench

    Mac OS 10.12.5 Sierra

    Strange issue. I installed Vectorworks like always. I left the Vectorworks 2017 folder (fresh install, new computer) sitting in my 'user~Applications' folder. Thats the main, regular old applications folder. I went to download some online content via the resource browser. It failed. Gave me an error saying I don't have the permissions to change my Vectorworks 2017 folder. Selected the folder, hit CMD+i to get info. Sure enough, I have administrator rights to that folder. Read and Write. Called Apple support. Asked why I wouldn't be able to write to that folder. Stumped, the support guy got two senior engineers on chat. According to Apple, apparently, you can no longer set permissions on the Applications folder itself. I attempted to add myself with administrator rights to the Applications folder. It fails. Since the Vectorworks folder is INSIDE the Applications folder, I can no longer download things using the Resource Browser in this configuration. This seems insane to me. Anybody else seen this? My workaround is to just move my Vectorworks 2017 folder to someplace else. Any suggestions? They suggested the desktop, but that is such a mess I hate to leave full application folders sitting on there. Apparently the 'Can't set permissions on the Applications Folder' is a new development or 'un-documented feature' on Apples part. This worked fine back in January when I built this machine. I'm guessing one of the OS updates introduced this.
  8. I did a test this evening with an old 13" macbook pro and a brand new, maxed out, 15" pro. Vectorworks took 40 seconds to start up on both systems. Does anyone have a beefy windows laptop (xps or a gaming laptop) to let me know if it is any better? Thanks!
  9. nikihoops

    Best Mac laptop for VW

    Hi all I'm thinking of getting a new laptop, a MacBook to be precise. So just wondering which is best? I'm using Vectorworks 2015 for architectural drawings and sketchup for architectural and interiors. I also use Photoshop a lot for photo editing & illustration/graphics! My current laptop is pretty rubbish when using sketchup for large models- constantly crashes! Thanks in advance.
  10. Hello, I have an issue with my new MacBook Pro 15" with Touch Bar and VW 2016 (student version). I installed VW 2016 after a clean install on macOS Sierra 10.12.1, updated the software on SP4 version and when I launch it, the software crashes while loading, more precisely when the pop-up menu "You are using an educational version of Vectorworks" and I click "OK". I already tried to uninstall and reinstall it. I also tried to launch the software without doing the SP4 upgrade (SP1). Same result. And I don't have yet access to VW 2017… Do you have any idea to solve my problem ? Thank you very much !
  11. Christian Fekete

    VW UI Font Size

    Is there a way to increase the size of the fonts used by VW in menus and OIPs? My eyes are getting less sharp and although the screens have become larger the fonts don't seem to.
  12. Hi, I noticed a weird behavior: I had two drawing windows open side by side (which, thank you for adding this functionality!), one on each of two monitors. The resource browser was positioned over drawing b, but I had drawing A active in the list of drawings. I selected drawing C in the resource browser (which was tabbed with drawing A), and tried to import a symbol into drawing A with r-click->Import. The import dialogue window opened and showed that I was importing into Drawing A and I hit OK. The resource browser then showed drawing B as active, and the symbol didn't appear in my drawing A resources. Moving drawing B back into the tab stack with A and C solved the issue. Hopefully that makes sense, but basically it seems like the resource browser wants to activate the drawing that it's floated over no matter what you have selected (bolded) as active within it when importing symbols. Drag and drop showed the same problem. Thanks for any help you can provide!
  13. Kevin McAllister

    VW Mac, Fonts and VW Cloud Services

    This post is about the how and why of fonts for Mac users who want to work with VW Cloud Services. It doesn’t deal with missing characters or other VW font issues. Its based on my four year journey of figuring out why VW Cloud Services wouldn’t work with my preferred font - ITC Avant Garde Gothic. I’m going to try to stick to my observations and stay away from editorializing my feelings about the experience. Its solely based on my experience of troubleshooting and in no way represents anything beyond that. On the surface VW seems to work fine with all of the fonts on my Mac but there are some hidden issues that seem to affect interaction with VW Cloud Services. My fonts for this demonstration are Century Gothic, Century Gothic Bold, Century Gothic Italic, and Century Gothic Bold Italic. I chose this font family because it appears on the VW Cloud Services font list ( https://cloud.vectorworks.net/portal/fonts/ ) and theoretically should just work. The version I used is a Truetype font. To access any of the styled fonts in VW you need to choose Century Gothic and then style it using the Bold, Italic or Bold Italic. You are able to select Century Gothic Bold as a font from the font menu and it will look ok locally on your machine, but it will not work with VW Cloud Services. Only Century Gothic styled Bold will work. Here’s what you get when putting a file containing the various incarnations of Century Gothic through VW Cloud Services. VW Cloud Services also sends this email about the missing fonts - The problem here is that in most cases these fonts aren’t actually “missing”. The Windows version of VW just can’t connect the dots that Century Gothic styled Bold and the font named Century Gothic Bold are the same thing. This is a failing in how the Mac version of VW writes font assignments into a file. As a secondary test, I typed some example text using Century Gothic, Century Gothic Bold, Century Gothic Italic and Century Gothic Bold Italic in the Pages word processor. I then cut and paste the text into VW. VW gets confused here too. With Century Gothic Bold for example, it assigns it the correct font but also adds a Bold style to it. (In some cases VW will generate a fake styled version of a font but that is not happening here. The generated version tend to have rounded corners, be slightly lighter weight and have other characteristics that make them distinguishable.) What does all this mean for Mac user's of VW Cloud Services? Here's some practical information I learned - To fix my problems with ITC Avant Garde Gothic I edited it directly in a program called Transtype 4. It allows you to convert, rename and organize font families. Any font pulled from a larger family needs to have a “regular” style present to work. Working in Transtype, that "regular" style needs to have all its technical names matching and its Parameters and Style Link Value need to be set to Regular. Stand alone fonts (eg. not part of a larger family) will also work if they conform to this naming convention. Any font I tried labelled “Opentype Postscript” or “Opentype Truetype” by Fontbook wouldn’t work. Fonts that seemed to works were listed as “PostScript Type 1 or Truetype in Fontbook. Odd styles like “Medium” or “Light” are styles that VW Cloud Services doesn’t seem to understand because VW doesn’t understand them. In almost all of these instances, fonts will work with VW on a local machine and behave fine. Its only VW Cloud Services that fails (and perhaps cross platform files, though in my testing my specific fonts worked fine with the Windows operating system itself. I didn’t test a full Windows VW installation.). Hopefully this help others to resolve their VW Cloud Services font issues. Kevin
  14. Mattheng

    Multiple accounts problem

    Hi, Have sorted out the main problems with the installations and am now getting all users on all computers up and running. When I install on a different user account on the same Mac I get these two messages when I am starting up. The user is connected to the internet and has full admin rights. Any ideas what could be wrong? Matt

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×