Jump to content

Search the Community

Showing results for tags 'fonts'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements
    • Announcements
    • News You Need
    • Job Board
  • Feedback
    • Wishlist - Feature and Content Requests
    • Known Issues
    • Wishes Granted / Issues Resolved
  • General
    • Troubleshooting
    • General Discussion
    • Architecture
    • Site Design
    • Entertainment
    • Vision and Previsualization
    • Braceworks
    • Rendering
    • Workflows
    • Buying and Selling Vectorworks Licenses
    • Hardware
  • Customization
    • Marionette
    • Vectorscript
    • Python Scripting
    • SDK
    • 3rd Party Services, Products and Events
  • Solids Modeling and 3D Printing
    • Subdivision
    • Solids Modeling
    • 3D Printing
  • Vectorworks in Action
  • Archive
    • Resource Sharing
    • Machine Design

Categories

  • Knowledgebase
    • Tech Bulletins
    • Troubleshooting
    • Workflows
    • How To
    • FAQs

Categories

  • Marionette - Objects
  • Marionette - Networks
  • Marionette - Nodes
  • Marionette - Menu Commands

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Occupation


Homepage


Hobbies


Location


Skype

Found 11 results

  1. Wish #1. Ability to set a default replacement font: For me the Font Mapping dialogue box always defaults to 'Arial' (which personally, I find abhorrent). I would like to be able to set a Vectorworks preference so that it defaults to Helvetica or whatever (anything but Arial). Wish #2. Ability to permanently replace a missing font in a file: Currently, the Font Mapping replacement is only temporary in that when you set your font mapping to replace a missing font (Helvetica for the missing Bell Gothic Light, for example), it appears that the missing font is no longer in that file, as everything is now showing up as Helvetica even on the Text OIP. There is no indication that what you are seeing a replacement font. But if you quit Vectorworks, turn the missing font back on, restart Vectorworks and reopen that file — it reverts back to Bell Gothic Light. So the Font Mapping doesn't actually change the missing font to the replacement font, it only visually shows up as the replaced font while in the file it is actually still defined as the original missing font. (To me this one feels like a bug). This makes it difficult to maintain document consistency.
  2. Running VW 2018 SP1 on Mac. We have a few fonts (specifically DIN) that we use for our drawings that are becoming distorted when exported to PDF. The characters become squished to look tall and narrow with lots of space between each letter. This is occurring in all text including titleblocks as well as drawing labels. Changing to a system font seems to fix this (tested with Helvetica). Unfortunately our title block was really designed around the DIN font, so changing the font would require a complete redesign of our titleblock. The problem can be fixed by checking the "rasterize text" option in the export to PDF window, but this is really not ideal. The font was working perfectly for us in VW 2017 and prior. Anybody else with font issues in 2018? Any possible solutions?
  3. Fatoxious

    Default font type

    Howdy folks, long time listener - first time called. i had a trawl through the search but couldn't find it and please excuse an obvious question - i'm self taught on VW. i'm running VW 2017 sp3 on PC. just looking to see how i can change the default font setting from arial? TIA. C.
  4. Ian M.

    Disappearing Text

    I am working in Vectorworks 2013 on a file imported from a DWG format and I can't get the text to remain visible, regardless of what font I set the text to. If I edit a dimension or a text block, it might stay visible for a moment, but minutes later, everything disappears. I have used the "custom modification" tool to select all text, I have set the class attributes to visible colors, all classes are turned on, and I have used "Font Book" to "validate" my font files. Enclosed file: "Untitled 2" shows my drawing with the font recently set to "Helvetica", which ought to be one of the most commonly used fonts. "Untitled 3" shows the same drawing a few moments later with none of the text visible... Untitled 2.pdf Untitled 3.pdf
  5. Hi, I have two separate issues. I've created a custom Smart Titleblock by editing a Vectorworks sheet border with our company logo and when I'm editing in 2d - the fonts show as desired but when I exit the symbol, they revert to some generic font. Is there anyway to change this? ALSO, when Creating Sheet Lists (Or Record Formats), is there anyway to add a record format that automatically creates assigns the Stacking Order of the sheet on the worksheet? I'd like to know what the record format for "stacking order" is. Thanks
  6. Andrew Davies

    Webdings - Grrrrrr

    Hi For some reason (can't pin point down when) Vectorworks has started defaulting too Webdings as a font. It looks fine on screen, but when printed it comes out as per the attached. Very frustrating as I need to go through (using select similar etc) making sure it's a correct font. Any ideas why? How.can I stop it using Webdings by default?! Thanks, Andrew
  7. Hi all, have been experiencing this problem since the 2008 version. Seems like it still exists in 2016. After I have typed the greek capital S (Σ), it does appear correct in the text box but after you confirm, it appears as (tm). This does not happen however with the lower case fonts which appear just fine. Have tried Arial, Arial Unicode, Times New Roman and a few others. This issue has been discussed again in this thread: Thanks in advance for any replies.
  8. Christian Fekete

    Title Block Font Control

    I created a new title block but I am not sure as to what controls the fonts used in the title block, it does not seem that the fonts used in the symbol stay as attributed once I insert the title block in a drawing. For example the fonts can be changed for most of the texts once in the drawing by changing the font from the font drop down menu with the title block is selected. At that time the fonts that I attributed in the symbol are not kept but are replace by the font selected in the drawing. The only fonts that seem not to change are the ones used in the "issue" and "revision" block. Am I doing something wrong? Here is my Title block.vwx
  9. Christian Fekete

    VW UI Font Size

    Is there a way to increase the size of the fonts used by VW in menus and OIPs? My eyes are getting less sharp and although the screens have become larger the fonts don't seem to.
  10. Kevin McAllister

    VW Mac, Fonts and VW Cloud Services

    This post is about the how and why of fonts for Mac users who want to work with VW Cloud Services. It doesn’t deal with missing characters or other VW font issues. Its based on my four year journey of figuring out why VW Cloud Services wouldn’t work with my preferred font - ITC Avant Garde Gothic. I’m going to try to stick to my observations and stay away from editorializing my feelings about the experience. Its solely based on my experience of troubleshooting and in no way represents anything beyond that. On the surface VW seems to work fine with all of the fonts on my Mac but there are some hidden issues that seem to affect interaction with VW Cloud Services. My fonts for this demonstration are Century Gothic, Century Gothic Bold, Century Gothic Italic, and Century Gothic Bold Italic. I chose this font family because it appears on the VW Cloud Services font list ( https://cloud.vectorworks.net/portal/fonts/ ) and theoretically should just work. The version I used is a Truetype font. To access any of the styled fonts in VW you need to choose Century Gothic and then style it using the Bold, Italic or Bold Italic. You are able to select Century Gothic Bold as a font from the font menu and it will look ok locally on your machine, but it will not work with VW Cloud Services. Only Century Gothic styled Bold will work. Here’s what you get when putting a file containing the various incarnations of Century Gothic through VW Cloud Services. VW Cloud Services also sends this email about the missing fonts - The problem here is that in most cases these fonts aren’t actually “missing”. The Windows version of VW just can’t connect the dots that Century Gothic styled Bold and the font named Century Gothic Bold are the same thing. This is a failing in how the Mac version of VW writes font assignments into a file. As a secondary test, I typed some example text using Century Gothic, Century Gothic Bold, Century Gothic Italic and Century Gothic Bold Italic in the Pages word processor. I then cut and paste the text into VW. VW gets confused here too. With Century Gothic Bold for example, it assigns it the correct font but also adds a Bold style to it. (In some cases VW will generate a fake styled version of a font but that is not happening here. The generated version tend to have rounded corners, be slightly lighter weight and have other characteristics that make them distinguishable.) What does all this mean for Mac user's of VW Cloud Services? Here's some practical information I learned - To fix my problems with ITC Avant Garde Gothic I edited it directly in a program called Transtype 4. It allows you to convert, rename and organize font families. Any font pulled from a larger family needs to have a “regular” style present to work. Working in Transtype, that "regular" style needs to have all its technical names matching and its Parameters and Style Link Value need to be set to Regular. Stand alone fonts (eg. not part of a larger family) will also work if they conform to this naming convention. Any font I tried labelled “Opentype Postscript” or “Opentype Truetype” by Fontbook wouldn’t work. Fonts that seemed to works were listed as “PostScript Type 1 or Truetype in Fontbook. Odd styles like “Medium” or “Light” are styles that VW Cloud Services doesn’t seem to understand because VW doesn’t understand them. In almost all of these instances, fonts will work with VW on a local machine and behave fine. Its only VW Cloud Services that fails (and perhaps cross platform files, though in my testing my specific fonts worked fine with the Windows operating system itself. I didn’t test a full Windows VW installation.). Hopefully this help others to resolve their VW Cloud Services font issues. Kevin
  11. +1 ^ I would also like to see the CONVERT TEXT TO POLYLINE more closely resemble the originating Font. It's not bad in some instances, in others (especially BOLD or ITALIC) much gets lost in translation.

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×