Jump to content

Search the Community

Showing results for tags 'ellipse'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements
    • Announcements
    • News You Need
    • Job Board
  • Feedback
    • Wishlist - Feature and Content Requests
    • Known Issues
    • Wishes Granted / Issues Resolved
  • General
    • Troubleshooting
    • General Discussion
    • Architecture
    • Site Design
    • Entertainment
    • Vision and Previsualization
    • Braceworks
    • Rendering
    • Workflows
    • Buying and Selling Vectorworks Licenses
    • Hardware
  • Customization
    • Marionette
    • Vectorscript
    • Python Scripting
    • SDK
    • 3rd Party Services, Products and Events
  • Solids Modeling and 3D Printing
    • Subdivision
    • Solids Modeling
    • 3D Printing
  • Vectorworks in Action
  • Archive
    • Resource Sharing
    • Machine Design

Categories

  • Knowledgebase
    • Tech Bulletins
    • Troubleshooting
    • Workflows
    • How To
    • FAQs

Categories

  • Marionette - Objects
  • Marionette - Networks
  • Marionette - Nodes
  • Marionette - Menu Commands

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Occupation


Homepage


Hobbies


Location


Skype

Found 2 results

  1. DCarpenter

    How to draw a true ellipse

    I know this has been talked about to GREAT lengths, but whats the solution? Has someone written a PIO that draws a true ellipse? ... I'm designing a fairly large production that revolves around a large elliptical stage with a lot of other custom elliptical pieces and would like them to be true. Looking for some direction from those who live in the forum. I've wasted a bunch of time reading past post that don't seem to come to a resolution. Any final words on this issue? Thanks for the help, Dave
  2. This first part is just an FYI for anyone working with the ellipse tool...I learned a simple a geometry lesson / offset tool function lesson, the hard way. Vectoworks has an ellipse tool which works well. However, an "offset" shape of that ellipse is another ellipse that is your specified offset at the North, South, East, West coordinates ONLY. The curves will not maintain that offset as they travel along the curve. I believe the amount of the variance depends on the shape of the oval. The project is a custom conference table with inlaid veneers. I created templates to create the relatively simple shape templates on a CNC. This is a 190" x 80" oval. There is a solid wood boarder around the oval that is 4" wide. We found...only after running the CNC...that the offset at, say, the South East point, is about 3 3/4" not 4". I found I need to break the ellipse down to a polyline to get the offset consistent around the curves. I don't work with ellipses much, and since CAD came along I haven't had to draw one by hand. So it never occurred to me that the ellipse's curves would vary since the proportion ratio is changing. PERHAPS THIS IS SOMETHING THAT SHOULD BE TAKEN INTO ACCOUNT IN THE OFFSET TOOL? It seems to me that if you want another ellipse "X" amount bigger or smaller, the ellipse tool will do that nicely. But if you want an OFFSET shape, it will no longer be an ellipse. The other problem that occurred with these files is rather peculiar. For the smaller inside oval I created two simple shapes to be be run on the CNC again, for templates to use in the hand work. One is a rectangle with a 1/2 ellipse clip removed from it, the other is the same ellipse used to take the clip...simply an inside and outside shape. Upon exporting these to DXF files, there are a couple of anomalies that occurred to the shape...a slight taper to the end of some of the lines going into the next vertex. I regenerated the shapes and re exported with the same results. Odd, but even more so since there appears to be no "vertex points" at those transitions from straight to something other than straight...not in vectorworks...AND not in AutoCAD where the odd shape shows up. AutoCAD "regen" does not make them disappear as you might expect if it was a screen drawing resolution issue. What does get them to go away in AutoCAD is to explode them from shapes into component lines...then the lines show up as straight lines all the way to the correct vertex. I didn't think much of this, until the CNC operator pulled the file into his toolpath program. This program not only read the tapered lines, but connected them across the rectangle - resulting in a very odd shape. Again this started as a simple rectangle, with a 1/2 ellipse clipped out of the middle of one edge. I have attached the VWX and DXF files in case someone has a clue what happened...was it a CAD monkey error or an export issue. If anyone has answers or tips on this export issue, please let me know. The answer here was to to do the simple drawing in AutoCAD from the start. Who knows when it will crop up again, however. Thanks. Sean Vectorworks Designer 2018 Conf Table Center Oval Templates.dxf Conf Table Center Oval Templates.vwx

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×