Jump to content

Search the Community

Showing results for tags 'debug'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements
    • Announcements
    • News You Need
    • Job Board
  • Feedback
    • Wishlist - Feature and Content Requests
    • Known Issues
    • Wishes Granted / Issues Resolved
  • General
    • Troubleshooting
    • General Discussion
    • Architecture
    • Site Design
    • Entertainment
    • Vision and Previsualization
    • Braceworks
    • ConnectCAD
    • Rendering
    • Workflows
    • Buying and Selling Vectorworks Licenses
    • Hardware
  • Customization
    • Marionette
    • Vectorscript
    • Python Scripting
    • SDK
    • 3rd Party Services, Products and Events
  • Solids Modeling and 3D Printing
    • Subdivision
    • Solids Modeling
    • 3D Printing
  • Vectorworks in Action
  • Archive
    • Resource Sharing
    • Machine Design

Categories

  • Knowledgebase
    • Tech Bulletins
    • Troubleshooting
    • Workflows
    • How To
    • FAQs

Categories

  • Marionette - Objects
  • Marionette - Networks
  • Marionette - Nodes
  • Marionette - Menu Commands

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Occupation


Homepage


Hobbies


Location


Skype

Found 3 results

  1. I've noticed that VW2020 sometimes hangs up when switching render modes, and the expected results are inconsistent. Sometimes, I get the spinning Mac OS ball (VW is unresponsive / hung up), and there's a long delay before the tea kettle displays and then begins to show progress. Since it works this way, it's hard to tell if VW is hanging up (freezing) or just taking its sweet time. I have a decent CPU/GPU and plenty of RAM. Finding these inconsistencies make the tutorial process really difficult because it's hard to know if you're doing something wrong or the program is behaving badly. At the end of this trial and error process, I took Jim's render styles and followed the same debug example below with a very simple file (4x4x4 cube on a small slab and a single light). Everything behaved as expected. So either VW has issues with rendering bigger, complex files, or Jim's tutorial file is bugged somehow. For file consistency and to make sure I'm testing the same situation, I am using an exercise file from the "Rendering in Vectorworks" tutorial, filename "02-renderworks-camera-effects-v01.vwx". The Renderworks styles I refer to (I.e., "Quick" and "High Quality Render" are styles that Jim is using in the tutorial). I am going through the Renderworks modes in Design Layers (not sheet layer viewports). For Fast Renderworks, this doesn't seem to be an issue, but for Final Renderworks, Artistic Renderworks, Hidden Line, Dashed Hidden Line or any of the Polygon settings, there is an issue for render progress and render behavior. If I select "Fast" and then switch to "Final", the tea kettle displays for a moment and then nothing changes. Similarly, if I go from "Artistic" to "Fast" or "Final" nothing changes. If I go from Fast --> High Quality --> Final it works as expected, even if I interrupt High Quality and force a switch to Final. If I work this way, the Final render only takes 30 seconds. Switching to or from hidden line always seems to hang up VW. Other modes hang up based on what mode is currently active. Debug Example: I'm in Open GL and I switch to Renderworks Style --> Quick Render - it works as expected, immediate tea kettle and it takes 43 seconds. Correct! I'm in Quick Render and I switch to Hidden Line - it hangs up for a couple minutes and the render doesn't tell me how long it took. But crazy that it takes longer than Quick Render. Doesn't display "Rendering Complete" text. I'm in Hidden Line and I switch to Renderworks Style --> Quick Render - it hangs up for a couple of minutes and then the render says that it takes 44 seconds. Hmm. I'm in Quick Render and I switch to Fast - it works as expected, immediate tea kettle and it takes 04 seconds I'm in Fast and I switch to Final - it just stays in "Fast" even though "Final" is selected I'm in Final (but it's displaying as Fast) and I switch to Renderworks Style --> Quick Preview - it works as expected, immediate tea kettle and it takes 51 seconds. I'm in Quick and I switch to Final - it works as expected and it takes 45 seconds. Correct! It seems that depending on the file I'm working in, the Final setting has different behaviors and different results. An update tutorial to how the different modes function in VW2020 would be extremely useful. For now, I'm going to use my really really basic file and try to go through Jim's tutorials that way. I sort of expect that there would be some kind of render cache somewhere that needs occasional cleaning for optimization purposes. Could that be it? Or am I fundamentally misunderstanding how rendering works in VW? QA issue? I don't know. It's great that there's a time / progress bar as well, but like the hang up issue, whether or not it functions as expected is inconsistent. Would be great if it showed "Time Remaining" as well...
  2. Thanks again to Dom C for the great workshop upon Marionette , that I attended in march. Now , weeks later , trying to pick up the thread, trying to redo an exercise builiding a network for an easy table. Desperate, that I messed it up, and I don`t unerstand ,why debugging doesn`t work any more, as soon as the offset data are connected to the move node?! And I don`t get any result. Maybe someone can s.m.s. (save my soul). Friendly regards Bernd L. 2017_04_23_Table_Marionette_Workshop_Test.vwx
  3. Version 6.1

    114 downloads

    This Node makes debugging more comfortable especially inside wrappers. You can select weather if the incoming values will be printed into a text object right under the node or into the python console. Time of the execution and type of the items can be printed optionally. I integradet the object type list from the appendix site to translate the type id into a string ( 5 = Polygon... ) You can also define filter conditions as Python statement in the oip of the node. Variable X is replaced by the values. Check out the example in the VWX.

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...