Jump to content

Peter Neufeld

Member
  • Posts

    721
  • Joined

Posts posted by Peter Neufeld

  1. 8 hours ago, johnrd said:

    I continue to be a little surprised at the situations where Vectorworks hasn't quite figured out how to deal with.

     

     

    Actually the very exact opposite is true - it's up to us to figure it out - not Vectorworks!

     

    I think the best way is to use the Create Contour tool from the 3D toolset and use that as the path for a Edit>Duplicate Along Path. If you do this on a NURBS Surface then it's a single NURBS Curve for each contour which is cleaner than doing it through a solid that has thickness so no tidying up. You might have to adjust the height of the created duplicates but that offset should be the same for all rows. Although slightly tedious I think this is the best method as the contours follow the terrain.

     

    37 sec, no audio movie enc.

     

    Cheers,

    Peter

     

     

     

    • Like 2
  2. Hello,

    You might consider the use of the Model>Surface Array command. Depending in how you break up the sections nonetheless it is a great command. At the very least you might array 3D loci to the surface to allow you to then snap the symbols in place. The file and screenshot enclosed are just a quick example. Perhaps the hardest thing might be getting the NURBS Surface (Base surface) correctly modelled. The symbol has to be a 3D only one and as a symbol its shape won't distort no matter the array numbers.

     

    Cheers,

    Peter

    1414995348_Screenshot2021-05-28at5_15_40pm.thumb.png.87125f5909ad9c91d5292e9aa9998582.png

     

    Symbol and Surface Array.vwx

    • Like 2
  3. Oh yes I agree and good to see - working efficiently is so important. It does depend a lot on the work being done of course. A lot of users have multitudes of RAM and it's just the 16GB limit that has been pointed out in some other forums as not being enough in spite of the processor accessing memory 5 times faster. Anyway if I was in the market I'd wait. To answer Evie's question I'd say the new M1 13" MBP is going to be fine.

     

    Cheers,

    Peter

    • Like 2
  4. The amount of graphics memory is probably the most important part of computing for Vectorworks, so you need a separate GPU with as much VRAM as possible. Clock speed is more important than cores for the CPU. Make sure you get plenty of RAM, and plenty of hard drive space. The new M1 chips are very exciting but they are limited to only being able to have 16GB RAM. This isn't enough for high end users. I'd hold out until Apple make any announcements about their M2 chips and new line up.

     

    Cheers,

    Peter

    • Like 1
  5. Dear Nathaniel,

    Ditch those symbols!

    In the Premium libraries there are now new symbols called "CLS (Australia)". The Australia Live Industry Alliance website had a news item about it in October. Thanks to CLS for investing their time for this as they have also supplied the necessary data for Braceworks calculations. We are hoping to have that implemented very soon for actual calculations.

    In the meantime check out the symbols which have been painstakingly redrawn to be optimised for use in the program by the great content development team at Vectorworks, Inc. They put in a huge effort for Australian users.

     

    This will not fix all your issues but at least you should be using these symbols as a starting point. 

     

    Cheers,

    Peter

    Screenshot 2021-02-12 at 9.32.01 pm.png

  6. Glad you have it sorted. The easiest way to learn anything about Vectorworks is to go to the Help. In this case go Help>What's this>tools>Workspaces>Workspaces and it'll open the Help to that topic.

    Generally speaking the only reason you need to customise a workspace is if you have external plug ins or want to customise some keyboard shortcuts. The downside is that if you move between offices you'll have to re-learn. It's also best practice to rebuild for each version.

     

    Cheers,

    Peter

  7. The message doesn't make sense:

    "You have selected only one object or you have selected an already cropped viewport. Please select an uncropped viewport and a crop object to create a detail viewport."

    Surely it should read "you have selected more than one object..."?!

     

    In Tools>Workspaces>Workspaces if your current workspace's location is in the user folder then it has been customised. It can be customised even just for saving palette positions. You should click 'Revert' in order to reload the installed workspace from your application folder. This is assuming it's a workspace issue. I'd hassle your local technical support people.

     

    Cheers,

    Peter

     

  8. Hello,

    In my Renderworks classes (remember when people could sit next to each other in a room?) one exercise I get them to do is precisely that of using Decals to create a label for a wine bottle.

    Not meaning to hijack this interesting thread but thought I'd mention it. Anyone got any good examples of Decals?

     

    Cheers,

    Peter

    Screenshot 2020-11-03 at 9.16.17 am.png

  9. On 10/17/2020 at 8:42 AM, Rick Berge said:

    Hey all,

    Pasting viewports between documents was a source of file corruption. (And this is only about between documents). There's been an Alert forbidding it for a really long time, and we didn't realize the impact of closing some of the remaining loopholes, didn't realize that users required it.

     

    There is a bug open to replace the now-missing workflow, and we'll get this addressed.

     

     

    Dear Rick,

    Yes please we really need this hidden work around to resurrect files - especially those that exhibit unexpected and unrepeatable problems because the files originated in older versions. That is files and/or templates that have been carried across over the years.

     

    Thanks,

    Peter

    • Like 1
  10. The only reason not to migrate a workspace is that any new tools or commands get orphaned and don't get placed where they were designed to go (ie they go into a 'new' menu for new commands or any new tools are popped into a 'new' toolset but not where they really should be). Also if existing tools have been re-engineered then they would have to be reloaded back into the workspace. Old migrated workspaces caused a lot of problems several versions ago when the migration was on by default.

    It's probably ok to migrate templates for a few versions but just don't do it for years!

     

    Cheers,

    Peter

     

    PS In the Tools>Workspaces>Workspace Editor you can export the workspace as a text file so you can keep a record of it and any customised keyboard shortcuts.

     

  11. Hello,

    In v2020 you had to group the viewports and individually paste into the new sheet layers. Then ungroup the viewport in the source file, use the Eyedropper tool to pick up all the viewport attributes and then go to the new file, ungroup the pasted grouped viewport and put down the viewport attributes. It worked a treat.

    Unfortunately this functionality has been withdrawn from version 2021 which is why I didn't mention it. I wish we had it back.

     

    Cheers,

    Peter

     

     

     

    Screenshot 2020-10-29 at 7.17.50 am.png

  12. On 10/27/2020 at 4:36 AM, willofmaine said:

    My main VW template has been around for many years and has been forwarded from one version of Vectorworks to the next (maybe via migration, more likely more often by creating a .vwx file in the previous version, and then opening and saving that as a new .sta file).

     

    Hello,

    We see a lot of weird things with old files. Even if a template has been resaved and recycled from an old version the file itself still originated in that older version. Often unrepeatable and unexplained odd things might occur. Unfortunately it is also common to come across (lazy?) users who 'recycle' old files by doing a 'Save As' and deleting everything after a job has finished but retain the file structure. I have seen files this year (v2020) that exhibited errant behaviour that originated in version 8. This is not version 2008 - rather Vectorworks 8 released in 1999!

     

    The reality is that to be really safe you need to be a purist. When setting up a new computer you really should install all programs from scratch and all settings accordingly. However it is too tempting to migrate everything across. Likewise with Vectorworks. Workspaces however definitely shouldn't be migrated which is why it's off by default in the Migration Manager.

     

    The good news is that it's easy to transfer a file structure to a virgin v2021 blank file.

     

    To Rebuild Design Layers

     

    Create a new blank document.

    • Right click in the Design Layer tab of the Navigation Palette and select new.
    • Select the second radio button Import Design Layers.
    • Click Choose and locate the original file that needs to be re-built from your computer or server.
    • Select the Design Layers you wish to recreate in your new file from the list. 
    • Click the option to Import Layer Objects  if there is any geometry in the file you wish to use, and select OK.

    The same method for classes and sheet layers.

     

    It's not possible for viewports to be copied across but it's probably less likely that your template might have viewports already set up.

     

    Cheers,

    Peter

     

     

  13. Jayden,

    The active working plane is wherever you are on the design layer, clip cubed or otherwise. The user origin also shouldn't be an issue with snapping and the Clip Cube. I'd make sure you are on the latest service pack and if you are, then you might contact your local tech support about this problem. In the enclosed screenshot I have set the user origin 1 mile to the left and am using a custom working plane with no problem getting snaps on objects on the same layer.

     

    Cheers,

    Peter

     

     

    Screenshot 2020-10-01 at 3.19.10 pm.png

  14. Hello (sorry I do not know your name),

     

    I think you have to document the problem including movies so that the engineers can reproduce and understand the problem. Make sure you submit it to https://www.vectorworks.net/support/bugsubmit

     

    Hidden Line Render doesn't work with the Clip Cube on Design layers so it might have something to do with that:

     

    468516465_Screenshot2020-09-01at7_32_27pm.thumb.png.9d653b5ff00b1732927422b6791cb8c6.png

     

    At least with section viewports the 'Hidden Objects Display' ties in somehow. I'm sorry I couldn't be of any help - hopefully more learned friends on this forum will be able to.

     

    Cheers,

    Peter

     

     

     

     

     

     

    • Like 1
×
×
  • Create New...