Jump to content

Dendecko

Member
  • Posts

    88
  • Joined

  • Last visited

Everything posted by Dendecko

  1. @Marissa Farrellfair enough, thanks for the quick response. I'll just brute force a couple of them as stock builds then. Appreciate your help with stuff!
  2. Hey Guys, Thanks for all the help so far. I have a question related to inputs in the oip. I am building a network rack in marionette and want to be able to place symbols into the rack for the different kinds of devices that will be installed on mobile racks. These are custom built so vary in size. Now I can build a couple of standard ones, in face I have already but am wondering if I can change the number of possible inputs in the object info palette by adjusting the rack height. I've shown an example where I have manually placed them within the object but want to figure out if I can automate it so I don't have a bunch of unused boxes in my OIP.
  3. Kept searching and found a workaround using @Marissa Farrell had created an auto number for object points that was pretty easy to augment to an auto numbering system. Probably not the easiest way to do it but worked out.
  4. Dendecko

    Autonumber

    Is there a simple way of creating an autonumbering system in marionette? Background I'm building a marionette network that will build network racks for me and I want to number each RU level.
  5. This is exactly what I was missing! Thank you so much. I did not realize there was a specific node that did that but rather a general node you would input the test into. Still wrapping my head around the logic on a lot of things but this helps so much. Thank you @sbarrett
  6. I've been looking for a bit but haven't found any current threads about this so if it exists please route me. I'm trying to create an if node with a test. I can't figure out how to input my test. currently it is just a simple "if x>=Y then Z+1, Z". if that makes sense. I am looking for just a nudge in the right direction as I can't figure out the correct way to approach this. Thanks in advance for your time!
  7. @m.grafHey, totally I was just trying to show the exact challenge by zooming in and showing the 3 had the exact same real number input for the x position while having different y positions. The larger script I think was just going to confuse what I was trying to do. It unfortunately turned out to be an in session bug. When I closed vectorworks and restarted it, it worked correctly.
  8. Hello, I'm building a repeating set of circles on a Y axis but my circles are appearing in different X axises even though they have the same x point going into them any ideas what I might be doing wrong? picture to explain. all circles should appear on same x position but different Y positions however that is not what is happening.
  9. @Nikolay Zhelyazkov Thanks for the quick response. In this case I could just convert them to a group though I'll have to rethink how I'm using them as a way to number and track things. Thank you!
  10. @Nikolay Zhelyazkov Been having an issue with data tags shrinking super small when printed unless the "reset all plug-in objects" on the print screen is unchecked. Do you know what would trigger that? Is there a way to stop them from shrinking? Info the tags are incorporated into a symbol. That was the only element that I thought could be triggering them but otherwise no idea.
  11. @Conrad Preen Cool cool, just trying to make sure I wasn't missing anything simple in order to make it automate the second rack the way I wanted it to. Thanks.
  12. @Nikolay Zhelyazkov I did try this but ran into a bug as shown where either on the 3d rack it showed as one big unit or as three units stacked on top of each other. Which unfortunately was not quite what I wanted.
  13. I am trying to create a custom light with 2 seperate moving tilt sections. Does anyone know how to build them so that both portions of the light will rotate on independent axis? I have 2 3d loci but they appear to be rotation based on just one of the loci so I'm trying to figure out how to remedy that but not sure atm. Any tips are appreciated.
  14. This is what I have been able to achieve, you can see 2 linked racks. the one I can make a rack frame with 3 parts which allows a single name to show but appears as though there is a single module on the second rack. If I try to give them their own, I only get to see half rack as an option which limits it to 2. Does that make sense?
  15. I'm trying to place 3 devices on a single RU of a rack. I can do 2 but for some reason I can't get any more than that. Can anyone guide me how to do this?
  16. @Jesse CogswellThanks, I'll see what I can do with it.
  17. @Jesse CogswellI had thought about that, and thought it would solve the visual issue it would then present itself as different instrument types on my documentation in lightwright which I think could be confusing and difficult to do counts. Thank you for the idea though.
  18. I'm attempting to yoke up instruments in 3d without messing up the top/plan view of my instruments. I've attached images of the current appearance of the plot. Part of my issue is I want the lights to rest next to the pipe not on top of it. The 3d locus is currently right in the center of the light and I can't seem to figure out what to do otherwise. My Goals 1 - to move the lights in plan view to the correct positions which are slightly offset in relation to the pipe. 2 - Maintain the 3d orientation and positioning in relation to the pipes in the 3d view. 3 - Not create separate drawings for my 3d and 2d build. Any thoughts or ideas are muchly appreciated.
  19. @Pat Stanford Fantastic. That worked. I didn't realize how much I used the keystroke until the last couple weeks where I've been working in the connectcad workspace for the first time. FYI I did not have to exit and reenter I was able to just delete the number pad 2 and add the keyboard 2 immediately and it worked. Thank you.
  20. @Pat Stanford ok so I figured a little bit out. This only occurs while I'm in the connect cad workspace, I tested different users and it still happened so I'm wondering if maybe it is an issue with connect cad workspace in 2021? not entirely sure cause I am pretty shallow when it comes down knowledge on all of this but I successfully checked on two devices, different users and the only through line is that it works fine in every other workspace except for connectcad.
  21. @markddSo for inputting the numbers Data tags have been really quick, do you know if it is possible to auto number a set of data tags that have already been generated with different incrementing numbers without selecting each one independently?
  22. Wondering if there is a way to select a collection of text fields and either auto number the text from left to right, radially, or any other way. Working on a collection of diagrams where I would like to do something similar. alternatively to auto generate them within certain parameters the way the duplicate array function works. I'm aware of a couple ways to do this but wanted to know if there were simpler methods. 1st, I know I could use spotlight to auto number by clicking objects I've made using its auto numbering tool. 2nd, I know I could use the number stamp to place them sequentially. 3rd, I know I could create a symbol and make linked text records and then do a quick data input after the first one. Just looking for any more elegant ways to possibly do this on the fly as I will have varying orientations in 2d space. I have an example of the basic numbering idea below that I would hope to do in a couple of clicks rather than manually typing each number or manually clicking on each numbered spot. Please ask if anything doesn't make senes. Thanks.
  23. I went into the workspace editor. Could only input with a command prompt, which should function as a workaround in the short term but I couldn't set a standard view, as far as I know, as an individual keystroke. I'll keep looking around but thanks again as that is at least something to start with.
×
×
  • Create New...