Jump to content

Hello Community!

This Thursday, October 21st, from 6 pm to 7 pm EDT, we will be performing an update on the Vectorworks Community Board. During this time, the site will be unavailable.

Selin

Vectorworks, Inc Employee
  • Posts

    127
  • Joined

  • Last visited

Everything posted by Selin

  1. Correct. Redshift renders as Realistic RW when system requirements are not met.
  2. @grant_PD you are seeing only that wall in exported document because you're exporting Selected Objects on Active Layer. That option will export selected objects ONLY. You must've started your export with one of the "All Visible Objects .." options if you are 'losing' geometry. By doing that, you are updating a Geometry null object (previously sent with all VW objects) in Cinema 4D to be a Geometry null that only has selected objects. Merging algorithm thinks you don't want the other objects anymore because you didn't include them in your scene. This is equivalent to deleting all the other objects. If you start with All Visible xxx and want to see all of them in export at all times, keep that setting the same during export. The way it is, you are not only changing a wall in the scene, you are changing the exported scene itself. The reason your way doesn't 'delete' geometry is because when you are merging a saved file and a new file, those scenes and Geometry objects and the objects under that are different, with different IDs. We're not updating the same scene in that case, we are merging two different scenes.
  3. Hi @Mark Aceto, we suggest OBJ, SketchUp or 3DS. These come in to Vectorworks as complete meshes with correct normals. If you're having trouble with the sizes of the files, check out Modify->Simplify Mesh on big meshes. It can significantly reduce mesh size without compromising the look or normals. I would also suggest looking into importing textures separately from .c4d files using Import Cinema 4D Textures. If you edit them in Vectorworks they become VW textures, but if you don't they live in the VW document as C4D materials, with all the settings from Cinema 4D, and they work great with export.
  4. Hi @grant_PD, could you please report a bug with specific issues and attach a test file so we can fix them for you? Send to Cinema command should display a scene organization dialog, and when you accept that dialog Cinema 4D should start up with the exported scene. I have never seen this command do 'nothing' so I'm interested in how you reproduce. Export to C4D is different than Send to Cinema4D, in that it will only save the exported file on the disk. It will not provide a 'working file' where you can keep merging incremental changes like the Send to Cinema command. In fact, starting with an exported .c4d file and then using Send to Cinema 4D will create two completely different files and merging is not guaranteed. If you start by the Send to Cinema command, then we will be working on the same file and can merge the changes. In that case, your geometry shouldn't be replaced, it should be merged. You folk probably already know these but I wanted give some simple tips for merging files to work seamlessly: Send to Cinema 4D functionality was overhauled a few versions ago. You can now choose different scene organizations from the export options dialog that pops up. Choose one that's most useful for your case and use the same scene organization throughout the session. For example, using Sort by Class in the first send and Sort by Texture later will break the merge. Changing object types will break the merge. For example, converting objects to symbols, grouping/ungrouping them etc. Changing scene hierarchy in Cinema 4D might break the merge. i.e. merging multiple poly objects resulting from exporting a wall, moving Null objects around in the document etc. Sorting by Texture is great if your workflow includes replacing VW materials with C4D materials. If you change the option Export Symbols as Render Instances in between merges, that might break the links with symbols. If you sort by class or material, changing the class name or material name might break the merge. If you sort by class, Vectorworks layers are translated to Cinema 4D layers Vectorworks classes become Cinema 4D layers if you don't sort the scene by class Changes in which software will take precedence during merging is controlled by Update Merge Options dialog that opens in Cinema 4D. For example, if you turn on Materials option from this dialogue, changes made to textures in Vectorworks will override changes made in Cinema 4D. Usually it's a good practice to keep geometry changes in VW and material changes in C4D. PS. Thanks @zoomer for raising this issue. I will test this on my end, but could you send me a file where you can reproduce reliably?
  5. Vectorworks has a built in Cloth shader under Reflectivity>Cloth. This shader is based on Cinema4D's Irawan(Cloth) shader model. Cloth presets define the weave pattern of certain fabrics, and you can fine tune the irregularities, shine properties of the cloth to get a velvet look. You can also add a Noise shader on top to get an overall rough feeling, and/or an Image shader for a pattern. I hope this helps.
  6. Hi @Kaare Baekgaard, could you send me the file you were using so we can debug this? OpenGL settings shouldn't affect this behavior.
  7. I've looked deeper into this and it is actually working as designed. Data visualization overrides the appearance of all objects. Because instances adopt the appearance of symbol definitions rather than the overrides, if we ignore data visualization and let export create instances, they use the color of symbols pre-data viz. Though plain geometry still uses data viz. colors. This creates a mixed effect that is wrong in any way. For data viz. to be rendered correctly, we need to disable instancing. Sorry for the confusion. When we can't have both, accurate renderings and exports are higher priority than file organization and other optimizations. I suggest turning off data viz. for symbol heavy exports like this and achieving your 'override' effect by modifying the symbol definition directly from Cinema.
  8. You can turn it off from the drop down menu next to the render mode drop down.
  9. Hi @Wesley Burrows upon investigation I have realized the reason for that is because you have Data Visualization on in your Design Layer. I'm not so certain about the reasoning yet but I'm looking into it. Meanwhile, turning Data Viz. off just for the export would be a workaround.
  10. Yes. This issue will be fixed in the next version. Sorry for the inconvenience.
  11. Hi @Sittingducks, clip cube sometimes smoothes surfaces it shouldn't. Can you please DM me an example file or send me an email so we can take a look at it?
  12. This issue is fixed in version 2020. Thanks for bringing this to our attention!
  13. Hi @cwetstein I'll answer the Renderworks part of the question. It will still be using CPU only, as RW is based on the CineRender engine and CineRender doesn't have GPU accelerated renderings as of version 20.
  14. A little update on the issue. So, in terms of Renderworks, the behavior for the Esc key hasn't changed. However, apparently because of OS updates, Renderworks doesn't know the key is pressed now. This issue will be solved in the next version, sorry for the inconvenience.
  15. Yes, @Andy Broomell This is a known bug assigned to engineers who worked on the Image Effects task. I pushed both for image effects and the OpenGL black background bugs to be fixed in SP4 but I'm not certain. They're both out of my hands now. @SNOJNKY this is a RW viewport and your image compression is set to PNG right? If so, this sounds like the hard to reproduce black RW VP bug. When you get the black viewport once, can you still use other Renderworks features? (Like successfully creating a texture)
  16. JPEG compression not working with RW was a known bug that was fixed in SP3. OpenGL is different though. I see a couple bugs about OGL black backgrounds, looks like it'll be fixed in the next version. VB-156254, VB-157004, VB-156910
  17. Yes this is different. The infamous 'black viewport' issue is when a Renderworks viewport consistently produces a fully black rendering. This one is in OpenGL and you can actually see the geometry rendered. Just the background is black. @halfcouple Do you see the background in the design layer?
  18. Is your default image compression JPEG? Does it work when you switch to PNG? Does it work with other RW modes?
  19. I'm afraid backgrounds won't make any difference @Zeno You might need to use a section viewport.
  20. What is your image compression setting? Try changing it from Preferences>Edit>Default compression to PNG. We have a known bug about JPEGs in SP2.
  21. Have you tried using an image bump shader with displacement or parallax? If not, try a pebble image with parallax first. Displacement might look better but it'll take considerably longer time to render.
  22. Hi @Zeno this looks like a Renderworks viewport. This is because we use C4D's (also CineRender's) boolean objects in RW to do clip cube, and they don't work well with normals. The geometry either looks faceted or too rounded sometimes. It also relates to normals and winding order not being too reliable in VW. OpenGL viewports shouldn't have this problem though.
  23. No problem, apologies for the hold up. JPEGs will be fixed in the next SP.
  24. Hi @klabeko, is your default compression (Preferences>Edit>Default compression) set to JPEG? I have tested SP2 as well and PNG compression works while JPEG renders white.
  25. I'm not able to reproduce this with SP3 beta (471167). It was probably fixed by a change between SP2 & SP3.
×
×
  • Create New...