Jump to content

nahekul

Member
  • Posts

    32
  • Joined

  • Last visited

Everything posted by nahekul

  1. @_James Same issue is happening with us. Publishing most recent issues will reverse the order. This is on macOS Catalina, and Vectorworks 2021 SP3.1
  2. @Matt Panzer This doesn't seem to work with VW 2021 anymore. The viewport when scaled in group becomes blank.
  3. Reference marker in Vectorworks 2021; Add the functionality for reference markers to link viewports from other Vectorworks files (similar to how the publish function works with multi-file publishes)? Primary use: - Allow plan/section/elevation files to link to separate details file.
  4. Regarding the new reference marker in Vectorworks 2021; Is there a way to link viewports to another Vectorworks files (similar to how the publish function works with multi-file publishes)? This is mainly because our office works with a separate details vectorworks file from the primary plan/elevation/section file. It would be ideal if we can link the reference markers on the plan/elevation/section file to the actual details on the details file.
  5. Hi, Is there a way to create a filter definition that contains multiple layer names? For example, if I want to filter out layers that are plans, sections, and elevation, I can add multiple criterias similar to how custom selection is done. Currently, the layer filter only allows one entry of each definition, so I can only create a filter that separate out plans, or sections, but not both at the same time. The current work around is to add 1 tag (eg. PSE) to all three types of layers and filter that tag separately. But this is not ideal since sometimes you want just plans and elevations or plans and sections. Then you need tags for those combinations as well.
  6. It looks like we may have found the issue. The problem occurs on the elevation design layer. On this layer, there are 24 viewports referencing back to the main floorplans (with lots of symbols and multiple layers turned on). Moving these viewports onto another design layer and turning it off when drawing on the elevation layer solves the slowdown issue.
  7. Yes, the file has been sent to the tech and they are looking into this. Thanks.
  8. The same thing happens with either "Best Performance" or "Best Compatibility" selected.
  9. We have noticed that Vectorworks slows down/freezes every time something new is drawn (eg. lines, squares, dimensions) on layers with a lot of objects (~1800 objects). Moving and duplicating objects are okay, just not drawing anything new. It happens with VW2019 SP2 only. Other versions seem to be fine. We think this is because Vectorworks is trying to redraw the entire design layer. If all the classes on the layer are hidden, then there are no issues with drawing anything. Drawing objects inside a group without showing other objects outside the group is fine as well. If there is a way to limit the redraw to the display area instead of the entire layer, then I think it should solve this issue.
  10. This has been fixed in Vectorworks 2019 SP2. Space objects now display the area correctly without the need to use the Record.Field format.
  11. @Tim C. Thanks, I have sent you the Vectorworks file that is experiencing the slowdown as well as the activity monitor report. Let me know if there are any issues with the file.
  12. We are seeing the same issue with SP2. Multiple files have spinning beachballs (sometimes up to 10min.) when changing layers and editing objects. This is solved when we move back to sp1.1.
  13. We are noticing this same issue happening with Vectorworks 2018 and 2019 as well. Our workaround was to restart the computer then disconnect and reconnect to the server. This seems to work but it's a bit of a hassle.
  14. Yes, all the database functions still work. It is just the regular spreadsheet function (=AREA(('Space'.'11_Number'='X'))) that does not. This is due to the space object not displaying an area for the polygon in the OIP.
  15. The area function in spreadsheets is not displaying space object areas in Vectorworks 2019. This has always worked in previous versions. Formula in spreadsheet: =AREA((((L='Design Layer-1') & ('Space'.'11_Number'='R1')))) Database still displays the space area correctly. The area formula displays correctly for polygons or rectangles. Probable cause: - Clicking on a polygon or rectangle will display the area in the OIP. - Clicking on the space object does not display the area in the OIP. Where the area should be is blank. V2019 Spreadsheet test.vwx
  16. Vectorworks Architect 2018 SP4 (Build: 435714) (64 bit) The bug occurs when trying to convert an unstyled wall to a new wall style using the right-click context menu. To recreate the bug: - select some unstyled walls and create a group. - exit the group with the walls still selected (selected walls inside the group are shown as not selected outside). - create another unstyled wall that's different than the first one. - right click on the new unstyled wall and turn it into a styled wall. - pop up menu will come up asking to replace all selected walls (no ways to not replace the walls). - clicking ok will now change all the selected walls in the group to the new styled wall even if the group is unselected and on another layer. There is no way to tell if something is selected in the group unless going into each group on every single design layer to check manually. The workaround currently is to copy the unstyled wall to a new file and turn it into a styled wall in the new file.
  17. This is still an issue on Vectorworks 2018 SP2. Holding ALT/OPT and clicking spacebar will also switch between the bucket and eyedropper.
  18. I've tried both a full preference reset and a fresh install and neither fixed the issue.
  19. Was this issue ever resolved? The shift lock is still not working as intended where it loses its lock as soon as the cursor moves too far from the locking point. Currently, the only method is the "T" (smartpoint) lock but that doesn't work when the cursor is hovering over a line (bug?).
  20. Yeah, it is almost always by accident since there's no way to check out the symbol definitions as you mentioned. So one user might be working on the unit symbol and another user accidentally access the symbol as well to make a quick change but has no way of knowing if another user has already edited the symbol until they do a save and commit. It would be helpful if there's a rename or duplicate the symbol with another name option so both users can figure out what has changed between the 2 edits. The conflict resolution dialog does appear for users online as well but usually, the problem happens when one user takes the file home to work on so they have no idea who is working on the symbol at the office. This creates a problem when there are hundreds of symbol definitions and multiple people working on the file. No one knows which one they are "allowed" to edit without a conflict dialog pop up during a save and commit.
  21. I see. It may be a bug in this case then because we are sometimes getting only half of the items committed to the project file. For example, lines and shapes would commit but not dimensions. The dimensions would then be released so further commits would not pick up those dimensions. Newly added objects and dimensions would commit but the old ones do not show up. The workaround was to cut the uncommitted dimensions (thus checking it out again) and paste in place. This allows these dimensions to be committed to the project file. Ah okay, I'll have to try the offline mode again. There was one question regarding the symbol definition conflict resolution pop up with the rename option grayed out. Example: There's a typical unit type symbol definition that occurs on multiple layers. User 1 (working offline) checks out layer 1 and works on the symbol definition 1 at home. User 2 (working online) checks out layer 2 and works on the symbol definition 1 at the office and saves and commits. User 1 gets to the office and commits all changes to project file, there is a conflict pop up to either overwrite the symbol definition, leave it as is, or rename the symbol definition (somehow this option is grayed out).
  22. Vectorworks 2018 SP2 (Build 401138) (64-Bit) Fundamentals, Architect, Renderworks Issues: When saving and committing a lot of changes, sometimes only some items are committed on to the server. Could it be possible that during the commit, if the data transfer is interrupted, only partial items are saved in the project file but it also releases the items that are not saved? Possible solutions/workaround: When this happens, it looks like we can use the "cut and paste-in-place" function to re-checkout the items and commit the unsaved items again. I don't think checking out the layer will check out symbols. So if a window or door is a symbol in wall, they will need to be checked out separately if they occur on other layers that's not checked out. The "custom check out" filter is hard to use if a particular layer has multiple symbols and trying to know which object to filter for which layer is difficult. Usually, we just use the "custom check out" to filter out every object and check everything out. Side note regarding the "custom check out" / criteria window: There doesn't seem to be a way to remove the particular criteria without removing everything from the bottom up. For example, if there are 5 criteria selected and then criteria 2 is no longer relevant, there is no way to remove it without removing criteria 3-5 first. Also, there doesn't seem a way to reorganize the order of these criteria.
  23. We have experienced the same issues with some commits not saving. I don't know if this has to do with the SMB/AFP file sharing protocol for macs. Working offline does not work properly anymore as you cannot just have the layers checked out but also all the objects on that layer checked out which is difficult/time consuming to filter out.
  24. It looks like this is still an issue with the latest version of Vectorworks. Groups within certain symbols become ungrouped as soon as you exit the symbol. The only workaround for this is to create a symbol within a symbol.
  25. This did not work for me either.
×
×
  • Create New...