Jump to content

MHBrown

Member
  • Content Count

    215
  • Joined

  • Last visited

Everything posted by MHBrown

  1. MHBrown

    Dimensions not working

    In VW 2018 with the latest SP. I go to edit a symbol in 3D. I want to check a dimension, so I go to a right elevation. I measure the overhang of a counter top. The dimension is distorted. Then it disappears. I switch to "Screen orientation only." Still it disappears. I change from "3D" to "working plane" in the OIP. Nothing. I know that for over 25 years I have been able to do this very, very simple action. This happens all the time in all sorts of views, not just in symbol edit. There is no reason for this and I'm sure it is an accidental change due to some addend "feature." I do NOT want to work in any mode other than screen plane due to the instability of the program. Look. It is like this. If I'm in an orthographic view--whether it's 1919 on a drafting board or 2019 on a computer--I am looking at true size projections. If that is the case I should be able to pull a dimension between two points parallel to the paper/screen. This. Is. Basic. Why are my dimensions either 1.) distorted 2.) invisible (just the blue handles) or 3.) visible, but no longer anywhere near my drawing. Do NOT tell me to put it in a viewport and use the annotation tool. I'm editing a symbol, remember? I want to be able to dimension, alter, or otherwise edit in orthographic views. Doing anything in a 3D view results in imprecise changes at best and pieces and parts slung to the far reaches of the desktop at worst. If I just wanted to slap together a massing model I'd use SketchUp or some other consumer CAD-lite system. I need precision. What is happening here with VW? By the way, "Screen view only" does not "stick." what is up with that? MHBrown
  2. MHBrown

    Dimensions not working

    I'm not even in a symbol or editing window now. I'm just looking at an object in front elevation. I have Screen Aligned only, all the other necessary boxes are checked and I STILL cannot draw a dimension line without it disappearing. So it is worse than I described before. I don't really see this as a "bug." A "bug" is something that was simply too odd to notice. You can't check every possible combination of moves. I know that. This, however, is more akin to putting a car into production, but forgetting to put rotors on the disc brakes. It is a fundamental feature of the car that it stop on command. It the same sense, a CAD program's number one requirement is that it show the size of things. The size, folks. That is what it needs to do. I can't believe that someone didn't try to take a dimension of an extruded square in a Design layer before this version was released. But that is apparently what happened and it is now exhausting to use. Please don't tell me VW2019 is better. I'll keep the devil I know for now until I hear that VW has staffed up or has abandoned its 18 month release cycle for something more attainable, 24 to 30 months maybe. Until then, I'll keep the bugs I know rather than trade for new ones. Thanks, however, for everyone's tips and suggestions. I have to say that usually someone has figured it out and is generous enough to take the time to let us all know. That is greatly appreciated.
  3. In VW 2018 SP56 on an iMac, High-Sierra, late 2017 The well-known bug that causes Renderworks renderings to render black at random times (or sometimes white) has apparently been ignored by VW. As far as I can tell, this has been going on for around three years with zero action. This is not acceptable! I am NOT going to restart every time something new does not work with this software. My renderings work fine in OpenGL, but do not render with the Renderworks engine. When. Is. This. Going. To. Be. Fixed.? Really. I am NOT "upgrading" to a new set of problems with VW2019 until I have satisfaction that the old problems have been corrected. You can also add the disappearing wireframe when editing inside symbols and/or groups. This is NOT an issue with my file since it happens in many files. Please. I want to use this software, but it's continuing lack of stability is killing my productivity. When will these bugs be fixed? MHBrown
  4. MHBrown

    Dimensions not working

    Thanks, Matt, but that doesn't work either...at least not all the time. It is a bit hit and miss. My definition of "working" does not allow for random failures, but it is always something to try when I'm stuck. To respond to markdd, I appreciate the explanation so I won't bang my head against the wall anymore. I appreciate your help very much. But this flaw is simply not acceptable. That's like saying "well, the volume works except when you are on even numbered channels" and thinking that's OK. It's not. It's not even close to OK. The whole point of symbols is to only have to edit the master file instead of all the instances scattered around the drawing. I'm not putting a dimension on it as part of a presentation drawing. I'm just wanting to see how big something is (in the latest case, I wanted to see if I was in compliance with the ADA for wheelchair clearance.) Don't tell me to use the tape measure tool, draw a line and look in the OIP, or some other workaround. That is the point. VW has become a rat's nest of workarounds for things that are fundamental to drafting: such as knowing how big something is. If I want to be a fine artist I'll get some paints, canvases and brushes and slop around shapes and forms. But that's not what I want in my drawings. I want precision. I want it available wherever I am in the drawing. Previous versions of MC and VW allowed dimensioning anywhere on any orthographic view. If that is not the case, the application is fundamentally broken. I know I need to pass this along to the VW folk, not here. So sorry for the misplaced rant. MHBrown
  5. MHBrown

    Dimensions not working

    I am on a Mac, High Sierra OS. Sorry for the omission. I usually put all that in, but I'm in a rush.
  6. MHBrown

    Dimensions not working

    Of course as soon as I hit "submit" I found it. I followed your advice. Nope. Still does not work. To be honest, I don't need anything other than "screen aligned" view. The other views are far too unstable. Even when I select "screen align only" it jumps back to one of the other views. I wish there were a way to remove the lines of code that give the other two options. Thanks again for the help, but it is still not allowing dimensions in orthographic views within the symbol edit (perhaps elsewhere, it works, but I don't have time to do VW's work for them.) MHBrown
  7. MHBrown

    Dimensions not working

    Thanks for the tip, but I don't see any menu that reads "Display Screen Objects" anywhere (what else would be displayed if not "screen objects"? Why would I want a blank screen?) I also don't see anything that reads Unified View Options and the VectorWorks "Help" menu is no help. Can you elaborate? MHBrown
  8. Yes. I have the latest service pack. Why do people always ask that? That has never helped an unknown problem. This is a big problem with VW not having the resources to do a major upgrade every year. Is there an SP for that problem?
  9. The Magic Mouse is not really good for Vectorworks because often the clicks don't "take." Most long-time users have gotten used to quickly clicking the tool palette (if not using a short cut) and then zipping back to the drawing. You have to linger on the tool for the Magic Mouse to work. You just can't click quickly and move away. It is super annoying and a backwards step in UI. I'm not sure why this is. MHBrown
  10. MHBrown

    cancellation of rendering

    It is 2019. I am rendering in Renderworks and it can NOT be stopped. Sigh. What is wrong with this software?
  11. When using OpenGL or Wireframe my model will disappear or parts will disappear. Doing a re-render does not help. Having the model disappear makes is very difficult to work on it. Is this a new "feature" that allows me to go play golf instead of working ("sorry, boss, the model does not exist. See for yourself")? I'm thinking that the random missing parts is some sort of criticism by the application. Since my MiniCAD days in the mid-1990s I've never seen such a mess as VW2018. We used to call a dead boat engine an "anchor." VW is not the equivalent of that for me. The only thing that works are the Renderworks settings. Even fast renderworks, however, means minimum ten seconds between mouse clicks. S.....L.....O...........W. I'm using VW2018 SP4. Any ideas as to what is happening? I'm on a iMac. See image below. Any help is welcome; this is very frustrating. MHBrown
  12. MHBrown

    Eyedropper tool seems arbitrary

    I agree with Jim. The eyedropper tool has devolved. It doesn't work on anything grouped (why not? This is an absurd flaw. Things are grouped all over the place in a VW document.) It works only around half the time on anything else. If you can't fix something, just delete it and send a message to your users saying that you have done so. It is much better to weed out tools and plug-ins that don't work than to leave them there because you are embarrassed about it. Be honest and honesty is nothing more than being able to deliver bad news. VW would be better off in the end with fewer tools, but where all the tools work. That said, will this tool be fixed anytime soon? I'm using VW2018SP6 and is not working. MHBrown
  13. MHBrown

    Wireframe and OpenGL missing parts

    OK, thanks. I'll try to get to it later on this month. Since it is intermittent it will be difficult to isolate, I think. Was this not a problem that many people had? I seem to remember that it was, starting around 2016 or so. If so, was it fixed?
  14. MHBrown

    Wireframe and OpenGL missing parts

    My understanding is that the "black rectangle" problem goes back aways and is not unique to my file. Also, it does the same thing with much smaller files with different items. In short, it's not my file. It has something to do with the Renderworks engine (OpenGL has no problem rendering a scene.) Thank you for your advice. I think I just need to wait for a fix from VW.
  15. MHBrown

    Wireframe and OpenGL missing parts

    Did all the upgrades. Still getting the black rectangle of death on rendering. Not Happy with this application. I rate it a zero.
  16. MHBrown

    Wireframe and OpenGL missing parts

    OK. I'm so sick of the "black rectangle" rendering bug that I'm going to try to update VW with SP5 and SP6. Crossing fingers...
  17. MHBrown

    Wireframe and OpenGL missing parts

    rDesign, thanks for letting me know about the service packs. I'm not going to upgrade due to the uncertainty that I'd be just be replacing unknown problems with ones I already know about. There is no reason to believe that SP5 and SP6 will result in a more stable version of VW. Just a different one. Thanks, Neil, for the suggestion about objects very far away (I've had objects whose distance were so far out it was given in scientific notation!) I checked that already and that is not the case...but it was a good thought. I think that after using the same file for over a year--with lots of rendering and textures--that it broke down.
  18. MHBrown

    Wireframe and OpenGL missing parts

    Thanks, Neil, I might have too many legacy symbols that I'm not using. Other than that, there is not really anything unusual. I have quite a few texture maps, perhaps 75 or so. But it's a interactive science area with lots of graphics and colors. I'm always careful with my polygon sizes and only use real geometry when I need to. VW's transparency maps, however, don't always render transparent. So if I have something punched out of metal, I have to actually punch it out. I'll try to clear out unused symbols and texture maps and see if that helps. I've generally used Strata3D for my color rendering and this is the first time I've tried to keep a project in one application. It is not really possible to model with precision in Strata and VW's rendering has gotten better so I've giving it a try.
  19. MHBrown

    Wireframe and OpenGL missing parts

    rDesign, thanks for letting me know about the service packs. I'm not going to upgrade due to the uncertainty that I'd be just be replacing unknown problems with ones I already know about. There is no reason to believe that SP5 and SP6 will result in a more stable version of VW. Just a different one. Thanks, Neil, for the suggestion about objects very far away (I've had objects whose distance were so far out it was given in scientific notation!) I checked that already and that is not the case...but it was a good thought. Neither to I have an extremely large object. I think that after using the same file for over a year--with lots of rendering and textures--that it broke down. At this juncture, VW is simply not robust enough to do even simple projects if the file is used too often. I'm not building a skyscraper; my projects are very modest in size...although the latest file is over 500mb. I think it is the repetition that eventually causes things to go crazy. Even after I put my model into a blank VW2018 file the images come and go.
  20. MHBrown

    Wireframe and OpenGL missing parts

    It is not a corrupt object, unless you are defining as "corrupt" any object in a drawing created in a VW2017 file and opened in VW2018. All such objects within seem to have a significant chance of being misinterpreted by the newer version software. But I would not call that a "corrupt object" since it is somewhat intentional. That is what appears to be happening, anyway. It is not behaving as if a single corrupt object were living inside the file. Anecdotal evidence, to be sure, but gathered over 25 years of using the software.
  21. Yet another bug in bug plagued VW2018. Dimension witness lines cannot be dragged out from the text end, only where the lines touch what is being dimensioned. This means you have to drag the "wrong" end of the witness lines into the work and then try to snap the lines back to where they belong. This means you have to zoom way in to make sure you are hitting the points you want to hit. VERY frustrating. Add to this VW's generally eroding ease of dimensioning (the snap points are chaotic and nearly impossible to choose without randomly running the cursor around the area and hope, by chance, to hit the point you want.) Has anyone else experienced problems with dimension lines in VW2018?
  22. MHBrown

    Wireframe and OpenGL missing parts

    Thanks for the advice, but none of that worked. It's sad to hear it is a chronic, across platforms problem. It better get fixed. Do other CAD programs have this type of problem? I am very much dissatisfied with the present state of VW. I won't be upgrading to VW2019 until all of these problems are fixed...and I'm not talking about work-arounds. OpenGL not working, the model missing from the screen. What could be more basic than being able to see one's work? And VW, do NOT give me that nonsense that my problems are solved if I start and start a project in one version of VW. It was YOU who decided to accelerate the upgrades to yearly without committing the resources to pull it off and YOU need to fix it. It may be a video card problem, an OS problem, or a VW app problem, but YOU need to identify it.
  23. MHBrown

    Publishing VW files broken

    Thanks. I'm mostly getting tired of having Vectorworks crash once or twice per day. I want to transfer to a new document, but VW has dropped the ball on that. There is no way to do this very fundamental action. Probably because it is "too hard" although "too hard" is not the same as "impossible." I want to do something analogous to an ID "package" where I could copy and paste an entire model and all the saved sheets, saved views, viewports, and elevation views would come with it. Alas, VW does not care about fundamentals, but would rather design little protractors for its rotate tool. At the height of its build, around VW12, I might go a year or more without a crash. Now it is at least once a day. I'd love to be able to downgrade back to that old version. I could not care less about the features added since then compared to the speed and reliability of the older version. VW has become as unstable as the old Strata3D of the mid 1990s--and that is saying a lot.
  24. MHBrown

    Publishing VW files broken

    I used to be able to export a set of VW saved sheets as a PDF. This straightforward, elegant system has been replaced in VW2018 by what I find to be an awkward and broken "Publish" command. When I invoke this, it neither gives me a chance to name the file nor choose where it goes. It acts like it is printing the file, but it doesn't print (by the way, if I wanted to print I'd choose print!!) When I press "Select Folder," it does not send the file to that folder. I have no idea where it goes, if it goes, or what name to search for (if you recall, there is not opportunity to name the file.) The "File Export Options" does nothing when selected. There is a menu with poorly named choices, but nothing happens regardless to what is selected. I get an annoying message that the Publishing was successful, but it is not. It then automatically opens my Vectorworks 2018 folder. This is a seriously rotten system and it needs to be fixed. It should work like this: 1. Publish (or export) to PDF 2. Choose files 3. Save as a set? yes/no 4. Name set 5. Choose Destination Folder 5. Options: PDF quality 6. Start. It is pretty simple. Please fix it. MHBrown
  25. MHBrown

    Viewports turn black in 2018

    The thread where I asked the original question was closed, but the problem has not been solved as far as I know. I'm sure that if one opens a pure VW2019 file that the black viewport rendering will not occur. But what about a file created in VW2018 or even VW2017? If VW insists on yearly major updates, the unintended consequence of letting the calendar (and not readiness) dictate major releases is the requirement that the update work with at least two older versions. This isn't because users are not updating---it's easy with a subscription--- but because sometimes projects will stretch across two years. There is no way that I know of to copy and paste the model, viewports, section views, elevation views, camera views, and more into a pristine file. Or is there? Thanks, MHBrown

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×