Jump to content

Simon Allan

Member
  • Content Count

    89
  • Joined

  • Last visited

Everything posted by Simon Allan

  1. Interesting to read you got better results with HLR in VW2020. I was curious so did a test on a simple drawing (5 viewports on one sheet, all HLR) that I am currently working on in VW2019. Here are the results. VW2019 (SP5.3)=345 seconds VW2020 (SP1)=373 seconds Like usual...disappointing.
  2. ok...All understood now, I think. So just to confirm, doing hidden line renders on curves may not be able to show a perfectly smooth curve? If so, is this a bug that can be sorted or "just the way it is"? Thanks
  3. OK, so why does the other object (the one using the non curved profile) render without issues? I have tried various segment amounts and it still seems unpredictable. Are you saying this is how I fix it? If so, can you please give more details as I could not find that command. Thanks
  4. Using an extrude along path (my path was a circle cut in half) and the same profile (with rounded corners) I get the same "faceted edge" result. The only difference was the 3D conversion setting behaved as expected in that it got worse the lower the setting was. It was still faceted when set to "Very High" though.
  5. @Charlie Winter My main focus is to get VW exchanging data with C4D via MVR. I am also interested in the potential with media servers especially relating to pixel mapping. I personally believe MVR will only grow and get widely adopted when it is working to a point that other 3rd party applications can utilise it.
  6. I don't use vision at all and and neither do any of my clients.
  7. Thanks. Hopefully someone can clarify if this is a bug or user error. I would have hoped that this particular issue (lack of rotation) did get looked into during SP3 testing as this was first brought up back in November.
  8. Thanks for looking at this Kevin. I changed the setting to low on the file I uploaded and it behaved as your pictures show. I also tried on another drawing (sadly I can't share that one) that has the same issue and lowering the 3D conversion setting had no effect. Neither did adjusting the segment angle of the sweep. I think it has something to do with the profile shape and that curves are present. It also might be a hidden line thing too. Either way, the behaviour, as you pointed out, does not make sense.
  9. Hi, Been having some issues trying to get a smooth sweep when using a profile that has curves in it. I have attached a simple sample that shows the error. You will need to zoom in on the edge to see it but it is not a smooth curve. I dont know if this is a graphics setting or something else. Any help appreciated. thanks. Sweep Issue_VW Forum.vwx
  10. Now on SP3 and still getting issues. I drew a new version (attached) of the test plot in SP3 just to be sure and when importing back into VW, all the fixtures disappear. The fixtures are in the drawing because I can select them...but that is because I know where they are. I also see the don't have the rotation info with them which was the main issue in the original post. From what I can tell, the difference between SP2 and SP3 was SP2 showed a place holder for the fixture. I know there have MVR updates in SP3 so I am not sure what is going wrong. Please advise as I am trying to get some progress on this much hyped feature. Thanks MVR Test Export_Rev03.vwx
  11. Hi Henry, I use VW, C4D, Stage, Corona and PS. I am still waiting for a 'one solution fits all' but in all honesty, I have given up as I don't think it will happen anytime soon 🙂 I change my workflow depending on the client and what they want but currently I am moving more to this: Starting in VW or C4D using stage plugin. Get everything built and then render with Corona but don't use any beams. Take various passes into PS and finish. Below is an image that is about 20% Cinema/Stage and the rest is PS. This was before I started using Corona. Whilst there is no VW in this, there is nothing to say that I could not have started the build using VW. I have in fact taken the C4D and imported in VW for CAD drawings. This is now the same Cinema file with loads more work put into it, mainly from Stage.It is about 80% C4d/Stage and the rest is PS. Again, this was before I started using Corona. Some more images from the above way of working. As you can see, there is a bit of a difference but the first method was way faster that the second. The second also allows for me to start animating but that is a fair bit more work to say the least. I would say the first method gives a more "conceptual" look whereas the second method gives a more polished look. I tend to prefer something that sits between the two though! If I did these again, I would have a slightly different approach in that I would use Corona and would end up photoshopping more beams, lens flares and atmospherics in. Another big factor is what render power you have and the timeline you are up against and that will often dictate which route I take. Stage is great to get set built and nice looking renders in a very fast way. Of course C4D can run a bit slow when you start trying to render hundreds of beams though 🙂 I did try rendering in VW but had the same frustrations other people mention. The stuff Evan and Wesley show are great examples of what can be achieved with different workflows and I recommend you take a look at the images on Evans website as there are many stunning examples. Seeing these is what got me looking at Corona (Thanks Evan!) and I have really enjoyed using it....but ask me again in 6 months and it maybe that I am using Octane or Redshift etc etc! In fact, a lot of the decision to go with Corona was because of my hardware...but if Apple produce another Pro let down then I am heading to Windows...but that is another story. I would say, looking at your renders that it is definitely worth trying to take them through PS before you make any decisions about other purchases though. I think if you held back on adding in all the beams and atmosphere in Capture and tried to add them in PS you may be pleasantly surprised with what you can achieve. I hope this info helps in some way but as long as you are prepared to pick the workflow that best suits the job and be open to learn new workflows, then you are off to a good start. Cheers Simon
  12. Hi Dave, I was curious so went back and checked my file as I am now on SP2. Here is what I found... I took the VWX file Mark supplied and added a straight piece of Tyler truss to it and updated the VPs on the SL. Below is a screen shot of the PDF produced using my Mac Pro. Specs in signature. As you can see, all is OK. I then went onto my MacBook Pro. Specs in signature. As you can see, things are still wrong. On the MBP I then rendered HL in the DL the corner block showed the simple class (blue box) but the straight piece did not and displayed correctly. See below... Both machines on SP2 running VW2019. The only difference is the OS version and graphics card. I then exported the file to VW2018 and all worked as it should on the MBP. All I can conclude is VW2019 is still not working as it should. I have included the VW file in case you want to try. @dbrumbach Hidden Line Truss_Visibility issue.vwx
  13. Kevin, Did you read my original post? I put my post here as it only involves VW at present. I am only trying to go out of VW and straight back in using the MVR. I have not introduced any third party software yet. I have read the wiki here https://gdtf-share.com/wiki/MVR_File_Description#Node_Definition:_Matrix and can see the rotation is defined but it is either getting lost during an export or import in VW...or maybe it never existed in the first place?
  14. I fully understand that you cannot state a date but I was hoping for a ball park estimate of which Month it is expected to fall into. I would also like to think you could tell me if the 2 fixes I am looking for are due to be implemented in SP3 (subject to all working out OK) or they are definately not due to be implemented. I don't think I am asking anything unreasonable here...just some basic info. After all, you are the guys who decided to market the hell out this MVR thing so please be prepared to give answers when people ask.
  15. Sorry, but your last post did not tell me anything. Please let me know if the fixture rotation info and scale definition will be fixed in SP3? Also provide an estimated date for SP3. Thanks
  16. I don't use Vision at all and have no intention of using it. I want to use MVR to work with other software and at present, there is no chance of that. Problems at present that need addressing are: Fixture rotation info Scale Definition (when you import into say Sketchup or C4D the scales are wrong)
  17. thanks for the update. so... When is SP3 expected to be released? Will the SP3 release of MVR support fixture rotation?
  18. @BSeigel @bbudzon Any update on this yet? I could not see any reference to MVR in the SP2 update...but I have have missed it.
  19. Just an update on this...I went back to the my original file and updated the VP's and all rendered OK. The only difference between now and back when I posted this was I have updated to SP1.1, so I guess it was a bug after all.
  20. Thanks for the reply. This has to do with the way that programs using MVR treat lighting fixtures. Not every program uses a lighting device in the same way that Vectorworks does, instead they often use native geometry and parameters for how the lighting device should appear and function in their program. For this reason MVR contains info for a light's 3D location as well as some info about the light. The receiving program then decides what object belongs at that location, what attached info is relevant, and how it should behave. I guess I understand but would have assumed that going out and then back into VW would mean the fixtures would have been there and not place holders. Maybe my expectations are too high 🙂 I would have to check up on this, but I might assume it has to do with the first answer. The rotation information is being applied to the geometry of a lighting fixture in a VWX file that is not being transferred through MVR. If true, this would be a sensible optimization for the future. To not have rotation transferred makes the purpose of MVR a bit redundant. I really can't see how MVR is "supported" without this most basic of functions. Not certain what the reason for this is. But I have had several experiences where similar objects ended up grouped together. Another thing I'll need to ask about, but it may just be to simplify the drawing. Please let me know when you have the answer to this. This sounds like it is working as designed. MVR was created to contain information about lighting devices, 3D Geometry/Locations, and textures. All other info may be extraneous and could lead to larger file sizes and possibly less performance. Seems odd that some objects follow one rule and other objects do not. Hopefully you can provide some more concrete answers soon as the more I look the more I feel that MVR is really not supported in anyway that makes it usable in its current form. I know you mentioned that it is still being developed and optimised but you guys really need to calm down on your marketing if that is the case.
  21. This video tells me it is supported : supported
  22. Hi, I have been experimenting with the MVR import and export functions and have some strange things I don't understand. I am hoping to get some answers/guidance 🙂 I have attached 3 files: The VWX Test Export is a simple scene with some truss and lights. Everything is classed and lights and truss have rotation settings on them. The MVR Test export is the MVR export of the file above. The MVR Test Import is the file above (MVR) being re imported and saved as a VWX file. I have not included any other software yet as I wanted to see what happened when I just went 'Out and In' to VW with the same file via the MVR import/export feature. This is to try and gain a better understanding of how the MVR feature is working (or not working) before trying to get it supported in any other software. So my questions are (relating to the "Test Import from Export" vwx file): Why are the lights being replaced with a "place holder" and not the actual fixture? Why do the light place holders contain no 3D rotation info for my lights as it was present in the original VWX file? Why do the trusses come back as groups? Why has everything other than the lights and the fan lost its class information? Thanks. MVR Test Export_Rev02.vwx MVR Test Import from Export_Rev02.vwx MVR Test Export_Rev02.mvr.zip
  23. Great list Kevin. In regards point 1, I currently only use it to render my sheet layer VPs and I usually just want PDFs so all is good there...when it works! If I understand you correctly, you would like the cloud to render your design layer VPs whilst you are working on the drawing? If so, I think this would be very valuable and would make my day so much more productive! Not sure about saving a rendered file back as I would much prefer to have a sync button (like project sharing) to notify that VPs had been rendered and after a sync they all appeared. I totally agree with all your other points. I would also like to see the ability to adjust layer and class states when using the web app to view a .VGX file. It would also be helpful to have the ability to save some layer/class "presets" so the viewer could easily switch between them.

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...